Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Best tried and Tru method for connecting rc to spark

Join
Aug 11, 2018
Messages
7
Likes
0
Age
43
#1
Uhm, I haven't been able to connect the rc to my spark from day 1, any good Links to get this thing connected. I've tried allot of the ones offered online. No success though...
 
Join
Jul 1, 2018
Messages
17
Likes
15
Age
40
#3
Uhm, I haven't been able to connect the rc to my spark from day 1, any good Links to get this thing connected. I've tried allot of the ones offered online. No success though...
Hi - I had similar issue at first. I fixed by ensuring the phone was paired to the remote control first by WiFi (with the drone turned off). Then turning on the Spark, and it then connected to the remote and has been fine ever since.

Hope works for you.

I think I’d done something odd in the initial set up to try to connect direct to Phone when I always wanted to use the controller.
 
Likes: Airgobbler

Rbigham29

Active Member
Join
Nov 9, 2018
Messages
26
Likes
7
Age
33
Loc
Gwent
#6
I heard somewhere that if you hold the power button down on the RC for 9 seconds it factory resets it maybe worth a try. Also I could not get my phone to pick it up first of all and that was because it was on 2.4ghz mode and my phone did not work on that frequency had to change it to 5.8ghz in djigo4 app. Hope some of that helps
 
Likes: Airgobbler
Join
Aug 11, 2018
Messages
7
Likes
0
Age
43
#8
I heard somewhere that if you hold the power button down on the RC for 9 seconds it factory resets it maybe worth a try. Also I could not get my phone to pick it up first of all and that was because it was on 2.4ghz mode and my phone did not work on that frequency had to change it to 5.8ghz in djigo4 app. Hope some of that helps
Will give this a try tomorrow and post back...
 
Join
Aug 11, 2018
Messages
7
Likes
0
Age
43
#9
Ok, to follow up with my problem... Ended up having to send in my rc for warranty work. The antennas I think we're broken internally and we're not emitting signal... Hence no signal
 

New Threads

Forum statistics

Threads
8,756
Messages
72,770
Members
12,868
Latest member
TurismoM