Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Connecting with Android

spedunkler

New Member
Join
May 31, 2018
Messages
2
Age
67
I have successfully connected to my Spark (RC) with my iPad, no problem, but I've been unsuccessful with my Android phone, a Nexus 5X running Android 7.1.1. In my Wi-Fi settings, it shows "Connected, no Internet" to the RC, showing "Spark-RC-688570". But when I go to dji Go 4.0 and step through the Enter Device process, I choose Connect to the aircraft (I've also tried Activate the Aircraft unsuccessfully, but I'm assuming that was already done on the iPad so I don't need to -- unclear on this), then Aircraft Combo, then Install the Battery, Start the Aircraft and RC, then I get to the screen (below) that says "Connect to the RC's Wi-Fi" and can't get any further. I've tried both going from it to the QR code (never works) and back to the Wi-Fi settings which still shows Connected, no Internet. Clearly the app doesn't see it as connected yet. I see other postings about OTG cables, but some say these are not supported by dji. Well, I'm not seeing any dji "support" anyway since their app isn't working. Suggestions?

upload_2018-6-4_8-27-50.png
 

Attachments

  • upload_2018-6-4_8-26-54.png
    upload_2018-6-4_8-26-54.png
    117.2 KB · Views: 36

CG

New Member
Join
Jun 5, 2018
Messages
1
Age
43
Loc
UK
Hi spedunkler,

I too use a Nexus 5X with no issues apart from what you state above. If you go into your current WiFi connection with the RC and forget it then re-connect then it seems to work. Don't ask me why it just does :) I have to do this every time I connect for the first time. If all fails, it works flawless with an OTG cable. I hope that makes sense and sorts your issue out.
 

Willard

Member
Join
May 9, 2018
Messages
11
Age
57
I have a Nexus 6p and struggled to connect to my Spark the first time. The connection to Spark's wifi was no problem, but there was a 2nd dialogue box on the phone I missed which warned that the network had no internet connection and did I want to connect anyway - until I agreed with this, the phone would not connect properly. Had this with the Spark initially and with the remote more recently (purchased separately). Hope this helps!
 
  • Like
Reactions: TonySoprano

Gary Benzion

Member
Join
May 1, 2018
Messages
9
Age
69
I have a Nexus 6p and struggled to connect to my Spark the first time. The connection to Spark's wifi was no problem, but there was a 2nd dialogue box on the phone I missed which warned that the network had no internet connection and did I want to connect anyway - until I agreed with this, the phone would not connect properly. Had this with the Spark initially and with the remote more recently (purchased separately). Hope this helps!

Try putting your phone in airplane mode, then turn on Wi-Fi, and scan for Wi-Fi signals. If you don't see the controller Wi-Fi turn the controller off and then back on. The phone will then see the Wi-Fi signals and connect. I know this seems like a long process but it only takes a minute or so.
 

spedunkler

New Member
Join
May 31, 2018
Messages
2
Age
67
Thanks for the suggestions.

I eventually did connect by restarting a couple of times, but then it identified a firmware update (to 01.00.0900) and I'm starting this email in the middle of trying that. I had to turn off airplane mode and go to cellular to download the firmware. But it seemed to connect again and I started the firmware update. Got to 5% of the firmware download and had to start again -- it had lost connection. Re-established that by forgetting and adding it again, and next time got through the firmware download and to 98% of completion of the update. The Spark had made lots of sounds and lights going off and on -- I remember something similar from my Phantom 3 update so that seemed normal. But at that 98% point it failed again, noting error 0x02080101 . I started over again and the progress got to 30%, and stayed there while I waited 10 minutes or so and then gave up. Rebooted aircraft and RC and Wi-Fi connection, and then it showed that it was at 99% but nothing completed. Started yet again and it just said it was connected, and now it *seems* fine. I checked the firmware by going to the About menu in dji Go and it is showing 01.00.0900, so it appears to have updated the firmware.

So maybe I'm good, but I'm taking my iPad with me as a backup....
 

Hotwire

Well-Known Member
Join
Jun 25, 2017
Messages
195
Age
121
Loc
Australia
The best way to work this is first turn on the RC and then connect your phone. Remember to enter your password like any other hotspot(set to remember the network). Then open the App and wait for the App (DJI Go 4) to interogate the RCs WiFi network to see if the network contains a drone, ie your Spark.
If the phone doesn't connect to the RCs network, the rest won't work. If the App can't find the drone, uninstall it and reinstall it. To connect directly to the drone the drone must be in the correct mode, see the manual. If the RC isn't connected to the drone, the App won't work either ie the RC has a green LED lit.
Android phones work just as well as iphones/tablets but with a few less features.
 

jsdhornby

New Member
Join
Aug 2, 2018
Messages
1
Age
74
Hi spedunkler,

I too use a Nexus 5X with no issues apart from what you state above. If you go into your current WiFi connection with the RC and forget it then re-connect then it seems to work. Don't ask me why it just does :) I have to do this every time I connect for the first time. If all fails, it works flawless with an OTG cable. I hope that makes sense and sorts your issue out.
I intend to use a Nexus 4 with my, as yet, unopened Spark. Can you recommend a specific OTG cable that you use?
 

New Threads

Members online

No members online now.

Forum statistics

Threads
14,217
Messages
116,660
Members
17,321
Latest member
paraelhogar