Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

DJi spark on FCC

mattitech07

Member
Join
Mar 30, 2019
Messages
22
Age
50
I tried to set my spark in FCC mode with fake GPS, but something gone wrong I don't see 11 channel but 32 channel in 5.8 Ghz. Please someone can help me, I very need it
 

webvan

Well-Known Member
Join
Jul 22, 2017
Messages
414
Age
42
There might be something at play with the latest DJI GO because I've switched to FCC mode (get the prompt to change regions) and I cannot see the usual 11 populated channels for 2.4ghz but 30 empty channels.
 
  • Like
Reactions: nilanjan118

nilanjan118

Well-Known Member
Join
Oct 31, 2018
Messages
667
Loc
Japan
I have never bothered to look at the channels. I leave the channel selection in AUTO mode. Once you make the forced switch to FCC mode, you will always get the prompt to switch back to the original mode every time you launch the Go4 app. That itself is an indication that you are in FCC mode. Also, the increase in signal range is quite noticeable.
 
  • Like
Reactions: Neebuz

webvan

Well-Known Member
Join
Jul 22, 2017
Messages
414
Age
42
Same here but I did that yesterday after switching back from OTG+2.4+Reflector where I was getting (barely) 2000 meters to Wifi+5.8 and getting weak signal at 400 meters. I had gotten the region prompt. Not sure why I was getting these blank 32 channels but after a reboot of phone, RC and Spark and going out and back to FCC the usual screen with 11 channels is back. Haven't had a chance to check the range but the range was probably "normal"...and with little headroom.
 

MarRoh

Well-Known Member
Join
Sep 3, 2018
Messages
108
There might be something at play with the latest DJI GO because I've switched to FCC mode (get the prompt to change regions) and I cannot see the usual 11 populated channels for 2.4ghz but 30 empty channels.
I have the newest DJI Go 4 App and newest Firmware for the DJI Spark (and Mavic Pro) and the "fake GPS location trick" works great. Also I got 11 channels in the 2,4GHz band and the signal strength is displayed correctly.
 

mattitech07

Member
Join
Mar 30, 2019
Messages
22
Age
50
I have the newest DJI Go 4 App and newest Firmware for the DJI Spark (and Mavic Pro) and the "fake GPS location trick" works great. Also I got 11 channels in the 2,4GHz band and the signal strength is displayed correctly.
So work also in the latest version?
 

webvan

Well-Known Member
Join
Jul 22, 2017
Messages
414
Age
42
Yes

I have the newest DJI Go 4 App and newest Firmware for the DJI Spark (and Mavic Pro) and the "fake GPS location trick" works great. Also I got 11 channels in the 2,4GHz band and the signal strength is displayed correctly.
Yes see my latest post just above I got the frequency display to work again, not sure what was going on yesterday.
 
  • Like
Reactions: MarRoh

webvan

Well-Known Member
Join
Jul 22, 2017
Messages
414
Age
42
I have never bothered to look at the channels. I leave the channel selection in AUTO mode. Once you make the forced switch to FCC mode, you will always get the prompt to switch back to the original mode every time you launch the Go4 app. That itself is an indication that you are in FCC mode. Also, the increase in signal range is quite noticeable.
After running the NLD app made available today on the forum (and DJI GO MOD 2.0) I noticed that before I take-off with the Spark next to the RC connected over 5.8Ghz I have 3 bars with the unmodded DJI GO app and 4 bars with the others. I do get the prompt to change regions with the DJI version and 11 2.4 channels so I'm assuming I'm still in FCC. Still that display discrepancy is odd. Will try a range test tomorrow.
 

webvan

Well-Known Member
Join
Jul 22, 2017
Messages
414
Age
42
So I did this range test, more or less. It's very obvious that the number of bars differs hugely between the stock DJI Go and DJI Go MOD 2.0. When the drone is next to the RC as mentioned above and also when it flies away. At 400 meters there are zero bars left in DJI GO and 2/3 on DJI GO MOD. However it was still connected ok so it might just be a display issue. Ran out of battery to push it further away to see where it lost the connection. Will try again next time ;-)
 

New Threads

Forum statistics

Threads
10,887
Messages
89,824
Members
14,886
Latest member
rvlahos