Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Gimbal stuck

Festijn

Member
Join
Jun 28, 2017
Messages
20
Age
42
Hello,

A couple of weeks ago I did a firmware update via the app. I let the update do and when I checked after 5 minutes I saw the update was done but also the gimbal overload warning. At the same time I saw I was forgotten to remove the gimbal protect hood. My ‘costly’ mistake. :eek:😰

With my next flight I had no problems during startup. Everything went fine. I could move the gimbal up an down.
But after a minute it seems to get stuck and the image is shaking.

I’ve got this now with every flight. It could be after 30sec, after 3 min,...

The strange thing is that as soon as I land an take up again (without intervening) the gimbal works again.

It is so strange because at first point there’s seems nothing wrong with the gimbal. When I test it on a table I can move it up and down quite a lot until some time it doesn’t react.

Is there someting I could do to solve this problem? In the mean time i’ve tried to downgrade firmware and reset to factory settings without result.

I hope there is still a solution.

Thanks for your help.
Grt
Festijn
 
  • Like
Reactions: Andre Levite

Andre Levite

WELL-TRUSTED MEMBER
Premium Pilot
Join
Jun 18, 2018
Messages
1,630
Loc
Treasure Coast of Florida
Web
how-to-spark.com
Hello,

A couple of weeks ago I did a firmware update via the app. I let the update do and when I checked after 5 minutes I saw the update was done but also the gimbal overload warning. At the same time I saw I was forgotten to remove the gimbal protect hood. My ‘costly’ mistake. :eek:😰

With my next flight I had no problems during startup. Everything went fine. I could move the gimbal up an down.
But after a minute it seems to get stuck and the image is shaking.

I’ve got this now with every flight. It could be after 30sec, after 3 min,...

The strange thing is that as soon as I land an take up again (without intervening) the gimbal works again.

It is so strange because at first point there’s seems nothing wrong with the gimbal. When I test it on a table I can move it up and down quite a lot until some time it doesn’t react.

Is there someting I could do to solve this problem? In the mean time i’ve tried to downgrade firmware and reset to factory settings without result.

I hope there is still a solution.

Thanks for your help.
Grt
Festijn
Try an IMU calibration. Try uninstalling and reinstalling the DJI Go app. These are long shots that have worked for others and only take a few minutes. It's cleared up some weird camera problems for me as well.

If you have a filter on the camera -- remove it. Remove sun hood as well. (kind of obvious -sorry).

Use DJI Assistant 2 program to reset gimbal and downgrade firmware (I have no firsthand experience with that one). Can tell if that's what you described you did.

If ask those fail I hope somebody has better solution. Gimbal repair by DJI quoted was $76. ThunderDrones has a good reputation too - he's active on MavicPilots Forum.
 

Festijn

Member
Join
Jun 28, 2017
Messages
20
Age
42
Thank you!

IMU calibration and downgrade I have already tried withoud succes.

I will try your other options. Removing uv filter and uninstalling the app.
Didn’t knew reset gimbal was possible via dji assistant. I’ll search for it.
 

New Threads

Forum statistics

Threads
10,912
Messages
89,975
Members
14,901
Latest member
Beuzo