Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Haven't updated Litchi since early '18 - should I?

mp43sniper

Well-Known Member
Join
Jul 22, 2017
Messages
54
Age
45
I've wanted to be able to do missions with Litchi on my Spark like my Mavic since I found the app last year. Being able to use Google Earth and program the above ground altitude, etc creates such an amazing video quality that it's really unbelievable to me even now.

But now that pre-programmed flights with the Spark are possible, I'm seeing some feedback complaints that updates may not have gone well. If I'm reading it correctly, I have version v4.7g

If the earlier version that I still have is better to use with my Mavic (meaning DON'T update), I'd rather just leave well enough alone. What are your opinions on this?

Thanks,
Craig
Thunderdrones customer - highly recommended!
 

New Threads

Members online

Forum statistics

Threads
9,486
Messages
79,565
Members
13,602
Latest member
yamomhalvaea