Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Manually select frequency band with RC

fredz

Member
Join
Jun 21, 2017
Messages
7
Age
40
IMG_2148.PNG Is there a way to manually select the frequency band in the app when using the RC? Mine just says 2.4 and I can't select another band. I'd like to choose myself. Is there no way?
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,871
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com
The frequency selection setting is currently only available when using an Apple device.
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,871
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com
Which version of DJI GO are you using?
 

fredz

Member
Join
Jun 21, 2017
Messages
7
Age
40
4.1.2 - and there is no way to select the band. Can you select it in iOS? Do you have a screenshot?
 

JaZzMaN251

Active Member
Join
Jun 8, 2017
Messages
29
Age
33
Mine also says 2.4Ghz, no 5.8Ghz on screen. I don't know why, but since it works, I'll just leave it like that :)
 

fredz

Member
Join
Jun 21, 2017
Messages
7
Age
40
Aha, same here. It works just fine, but then I wonder why some can fly on 5.8. 2.4 is better for distance in any case.
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,871
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com
4.1.2 - and there is no way to select the band. Can you select it in iOS? Do you have a screenshot?
Here's what I see in iOS:

iOS.jpg
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,871
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com
I might be wrong, but isn't 5.8G only available with the Remote?
5.8G is available when connected via Wi-Fi when using the remote controller or just a mobile device.
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,871
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com
Have you actually tried to select a frequency and channel and succeeded?
Yes. Here's what I did:

1) Connect to the remote controller or Spark Wi-Fi network.

2)
Start DJI GO.

3) Go to the "Wi-Fi Settings" section of DJI GO and select "2.4G" or "5.8G" (depending on your desired Channel Mode).

Channel1.jpg

4) Select the desired Channel Index:

Channel2.jpg
Note: You'll be disconnected from the Wi-Fi network after selecting the Channel Index.

5) Connect to the remote controller or Spark Wi-Fi network.

6)
Go back to DJI GO and verify the new Channel Mode and Channel Index selections.
 

Peter

Well-Known Member
Join
Jun 2, 2017
Messages
97
Age
64
Yes. Here's what I did:

1) Connect to the remote controller or Spark Wi-Fi network.

2)
Start DJI GO.

3) Go to the "Wi-Fi Settings" section of DJI GO and select "2.4G" or "5.8G" (depending on your desired Channel Mode).

View attachment 210

4) Select the desired Channel Index:

View attachment 211
Note: You'll be disconnected from the Wi-Fi network after selecting the Channel Index.

5) Connect to the remote controller or Spark Wi-Fi network.

6)
Go back to DJI GO and verify the new Channel Mode and Channel Index selections.
Thanks, that is exactly what I did but it reverts to 5.8ghz every time after the wifi reboot.

If you have the time and inclination, would you mind trying that but instaed slecting 2.4ghz and select say channel 1 as that appears to be the least busy channel here. I would be really interested to find out if you can get it to stick as ne 2 separate occasions now, DJI supprt have told me that it is not available to users to select. I'm in the UK so I don't know if that has a bearing or not.

I desparation I've refreshed the firmware just in case that might help the range. My final trial before it's returned will be with an Nividia Shield (I hear processing power may be important), OTG cable, bluetooth and wifi will be turned off on the Shield (and my phone) plus I will refresh the RC/Spark wifi at the field. Fingers crossed.
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,871
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com
would you mind trying that but instaed slecting 2.4ghz and select say channel 1 as that appears to be the least busy channel here.
I'm able to switch between both frequencies and select any channel. My selection is always remembered after reconnecting to the Wi-Fi network.

DJI supprt have told me that it is not available to users to select. I'm in the UK so I don't know if that has a bearing or not.
That could be the key to this mystery. The Spark FAQ includes the following:

Q: What Wi-Fi frequencies does the remote controller support?
A: The remote controller supports 2.4 GHz and 5.8 GHz dual‑band Wi‑Fi frequencies. 5.8 GHz transmission is not available in some regions due to local regulations.
 
  • Like
Reactions: Peter

Peter

Well-Known Member
Join
Jun 2, 2017
Messages
97
Age
64
Thanks, I'm very grateful to you..

I did read that but 5.8ghz is available to me, it's 2.4 that I can't seem to switch to and hold on to. That implies that, and given it is the standard frequency for wifi it makes sense, 2.4 will be available everywhere. I do see 2.4 pop up occasionally so it is there.

I'll perservere while I'm waiting to hear from DJI about returning my Spark.
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,871
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com
I do see 2.4 pop up occasionally so it is there.
What do you see when 2.4 is not available? Is the "Available Channel" section hidden?
 

Peter

Well-Known Member
Join
Jun 2, 2017
Messages
97
Age
64
Sorry, I meant that I do see 2.4 pop up in the main screen (top right) indicating that it's transmitting on 2.4 although 99% of the time I see 5.8 there.

The 2.4 option is always there when going into the menu and it shows the channel activity fine so it must be working.
 

Ender

Well-Known Member
Join
Jun 2, 2017
Messages
91
Age
51
---numbers are for CE country---

I think there is a mixup of WiFi for smartdevice and "nit really Wifi" for Tx <--> Spark Connection.
(Either in our minds or in the Software or ???)

Using the simple means of unplugging the UFL Plug to the small internal PCB Antenna i proved that the visible WIFi is sent using that PCB.
And thats where we connect to with our smartdevice.
And MAYBE thats just what we can adjust in the WiFi Settings in DJI GO.

Using an RF Meter directly coupled to the two external Antennae i also established that 2.4 & 5.8 GHz signals are roadcasted at the same time whatever you do in the DJI GO Settings.

And i *guess* the little Wifi Icon in the top bar of DJI Go means that the Sparkis *using* only one of these frequencies, whatever it thinks performs best without us beeing able to influence that choice ?!?
(AS i assume the settings are for the regular WiFi of the small PCB).

If that is all so THEN the automatic choice is really wrong, in almost all cases it quickly shows a 2.4G icon and THEN shows 5.8G (1-2 seconds,COULD be just the GUI initializing).

One time it stayed at 2.4G and THEN the performance and range was acceptable, also the penetration was okay. ([email protected] Altitude, flying behind a huge tree at 150m distance without signal loss).
All other times it defaulted to 5.8 G and the Performance was awful (maybe 200m max and loosing connection if flying behind a small tree at 20m distance, typical for 5.8G.


SO if someone knows more,please share, will you ?

;-)

Ender
 
Last edited:

Hansd

Well-Known Member
Join
Jun 20, 2017
Messages
47
Age
63
Loc
Netherlands
One would expect that lower frequency (e.g. 2.4 Ghz. vs. 5.8 Ghz) would give you longer range - this is common physics, But the Spark manual states otherwise depending on the region/transmission standard. For FCC range is the same (1.2 miles) for both frequencies, for EC range is longer for the lower frequency as expected, and for the SRRC range is even worse for the lower frequency. Weird.
 
  • Like
Reactions: Firstrun

New Threads

Forum statistics

Threads
12,422
Messages
104,164
Members
16,147
Latest member
MarioBoost