Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

No video feed in latest go 4 app- fine in older app??

Ophidia Snaketongue

Well-Known Member
Join
Dec 7, 2017
Messages
114
Age
45
Hi folks,

I've had some time off work, so I decided to be unfaithful to my sweet Android 4.1.15 go 4 app and finally try out the newest version, 4.3.2. However, I instantly ran into a problem: no camera feed in the app! I tried the spark again with 4.1.15, and the video feed was fine. I googled some possible solutions, and I have tried the following:

- Downgraded to a previous version of DJI go 4: camera feed returned.
- Upgraded RC firmware to the latest. Spark was already running the latest firmware.
- Connected via wifi and OTG: no change.
- Uninstalled and reinstalled 4.3.2: no change.
- Tried powering up the drone with props removed: drone responded
- Took a photo using the remote controller buttons: successful. Photo visible on SD card, and also within the Dji go 4 app in the photo and video library
- Formatted the SD card: did not resolve problem.

There are two things I could think that could be causing this: plain old incompatability between the newest app and my tablet (thanks, DJI), or more likely the fact I had the gimbal replaced over summer after a bad crash (due to the pilot being an idiot). Could it be there is some sort of disconnect between the gimbal's firmware and the Spark? I am rather hesitant to try rolling the firmware back and reinstalling it, since I had heard tales of this bricking Sparks.

Any ideas? I can live with this if need be, since it still works fine with 4.1.15, but I felt like trying out the new bells and whistles in the latest app, since I was thinking of getting a mavic 2 :D. The tablet is an Acer Iconia one 10 B3-A10.
 

lmel2005

Well-Known Member
Join
May 15, 2018
Messages
655
Age
62
I think, the incompatibility scenario is most probable.

Borrow a different device and test, or just your cellphone (if it's capable enough).
 

Ophidia Snaketongue

Well-Known Member
Join
Dec 7, 2017
Messages
114
Age
45
unfortunately, I don't have that luxury- my phone is an older model, and none of my friends are very tech-savvy and don't have modern devices to lend to me.

I did see a thread on something similar on the DJI forum, where the camera feed had stopped working on upgrading the app- and DJI replied that there was something wrong with the video transmission module on the aircraft, and that it needed to be fixed. Yeah, right, DJI, that's why upgrading the app caused it!:rolleyes:
 

Starnow

New Member
Join
Oct 18, 2018
Messages
1
Age
36
Check the application's permissions and grant access to the camera.
 

New Threads

Members online

Forum statistics

Threads
12,886
Messages
107,688
Members
16,437
Latest member
craigimass