Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

PowerBoard weird issue

nicomoralesa

New Member
Join
Nov 15, 2021
Messages
1
Age
18
I bought a crashed DJI Spark for dirt cheap and fixing it has been a pretty good way of distracting myself of my other stuff but i've hit a roadblock. Today I got a new and working battery with 0 cycles after 3 that didn't charge and got the opportunity to try all my work but when i got to connecting it, the app would say there was an ESC error but all 4 of my lights were turning on and all 4 motors sounded when i turned the drone on. One of the things i needed to replace was the frame that comes with the Power board preinstalled. I started testing and downloaded the DJI Assistant 2 with the Debug Mod and got to try the motors and realized that M4 and M3 had no problem but M2 wasn't working and M1 was moving both front motors. It looks like a short in the TX line but it's not. Has anyone experienced something like this? Could it be my motherboard that is failing? i'm getting no other error and even the gimbal and camera are working fine, it's just that! I'll update a video showing the issue, it's in spanish as english is not my first language but I think that it makes the situation clear
 

SoccerRef12

Well-Known Member
Join
Jul 5, 2019
Messages
723
Age
70
Loc
Lampasas, Texas
You are getting into some complex issues, but I would try finding another motherboard if that's where you are getting the errors. I wish you the best and keep posting updates on how you are progressing.
 

New Posts

Members online

Forum statistics

Threads
14,356
Messages
117,479
Members
17,504
Latest member
SimpleSteeve