Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

RC and Spark connection

Joined
Mar 26, 2018
Messages
14
Likes
12
Location
Albuquerque NM
#1
Hi everyone,

I just got my Spark and have had limited time with it. I initially got the radio controller to connect and use the RC. Now I am not able to connect the Spark and the RC.


I bought the Fly More Combo and they should be linked from the factory. When I turn on the RC and the Spark, I am seeing two different Spark SSIDs when I turn on my phone WiFI. One is the RC and one is the Spark. Which one should I be connecting too?

I think I have used the link process (multiple times) when I should just be just doing a connection?? Is there a difference?

What is the correct way to connect the RC and the Spark?? I much preferred the RC than using the virtual control sticks on my phone.

Thanks for any assistance!!
Jerry
 

jmbsmt63

Active Member
Joined
Mar 17, 2018
Messages
38
Likes
13
Age
55
#2
If you want to use the controller to operate the Spark, you must connect your phone/device to the RC only.
The RC will connect to the Spark automatically if linked as part of the Fly More Package.
There is a possibility that performing updates or just holding the batteries power button too long might've erased the "linking"? If I remember correctly, holding the button in is part of the linking procedure?
I would "forget" the Spark's WI-FI (if you ever did connect using the phone) on your phone/device so that you are not accidentally connecting to that instead of the RC?
You should try re-linking the RC to the Spark as if you ordered it separately. I don't remember the exact procedure but there are plenty of tutorials/videos with instructions
 
Last edited:
Likes: Formerly450
Joined
Mar 26, 2018
Messages
14
Likes
12
Location
Albuquerque NM
#3
Thanks, for the info. It never says anywhere (that I saw) whether to connect the wifi to the RC or to the Spark. I have been connecting to the Spark. Which works if using the phone as a controller.
 
Likes: jmbsmt63

jmbsmt63

Active Member
Joined
Mar 17, 2018
Messages
38
Likes
13
Age
55
#4
Thanks, for the info. It never says anywhere (that I saw) whether to connect the wifi to the RC or to the Spark. I have been connecting to the Spark. Which works if using the phone as a controller.
You're welcome,
I agree the info is not as clear as it should be. All the videos, etc surely help fill in the blanks. I spent the 2 days waiting for mine to arrive watching/reading all I could about the Spark.
 
Joined
Apr 21, 2018
Messages
19
Likes
2
#7
Had the same problem took me two hours to connect my controller to the Drone if you wait till the green light on the controller comes on before you hook up your old TG cable it looks stand your range of your spark
 
Joined
Aug 17, 2018
Messages
13
Likes
2
Age
62
#8
I'm having similar problems using an OTG cable. Connecting requires reconnecting the cable, 9 seconds push on the aircraft button and 3 button connect on the controller. There must be an easier way.
 

jmbsmt63

Active Member
Joined
Mar 17, 2018
Messages
38
Likes
13
Age
55
#9
I'm having similar problems using an OTG cable. Connecting requires reconnecting the cable, 9 seconds push on the aircraft button and 3 button connect on the controller. There must be an easier way.
All that you are describing is to connect/pair the Remote to the Spark with WIFI and that should only need to be done once. OTG is between the phone/device and the remote controller. The Remote is "paired" to the Spark. Actually, if using OTG, you should turn WiFi OFF ( airplane mode) on the phone/device! You should not have to do anything on the Spark or the controller to use an OTG cable...Power on the Spark then power on the Remote Controller (RC) and just wait a few seconds for the light on the RC to turn green....Then attach the OTG cable to your phone/device ( device in "airplane mode")...It should ask to open The DJI app as default ( but you can still open the app manually if needed) with the cable attached or least show that a cable was connected if not, try reversing how the cable is hooked ( which end goes to where and which is connected first)...When the App starts it should show connected and the go fly icon should appear ....then you are good
 

Spark 317

Well-Known Member
Joined
Jul 10, 2017
Messages
1,603
Likes
724
Location
Indiana, USA
#11
you should turn WiFi OFF ( airplane mode) on the phone/device!
That makes it easy. Great explanation. Thanks.

On some devices, Airplane mode does not turn off the WiFi, just the data connection, so that you can still use WiFi on an airliner where available.

Go into your device settings to insure that the WiFi is OFF, guaranteeing a solid hookup with the OTG cable when used.
 
Joined
Aug 17, 2018
Messages
13
Likes
2
Age
62
#12
That makes it a sure thing. Thanks. Probably the same deal when using DJI goggles I guess. OTG cable and wifi off.
 

New Threads

Forum statistics

Threads
7,573
Messages
63,573
Members
11,167
Latest member
Babydave