Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Signal lost almost every flight

az erik

Active Member
Join
May 1, 2020
Messages
30
Age
45
Hi all. I picked up a refurb spark about 2 months ago. Logged a few flights but from day one I lose signal to the bird.I used to think it was wifi interferance but I've switched channels all around with no luck as well.

I've always been on the latest firmware and IOS go4 app.I use an OTG cable pretty much every flight. I have noticed if I set the spark in flight mode with just my phone I have to rebind the remote. I've followed the start up procedure as I've read here. Spark, Remote, OTG into the phone then app. Strange thing is when I lose signal I seem to lose the recording on the card as well. When I see choppiness in the files on the phone I also see it in the card. Almost like the whole Spark is choking.

What could cause something like that? Bad or faulty unit? Can I find this somewhere in a log by chance from the Spark?
 
  • Like
Reactions: ZPARK

MannyCAM2001

Well-Known Member
Join
Jan 29, 2018
Messages
524
Age
66
So sorry to hear about your bad experiences so far. As far as the rebinding, in my experience I always have to rebind back to the remote after using just a phone or any device for that matter. Are you flying from the exact place everytime? How far away does the disconnect happen? When you do lose the signal does the RTH kick in?
 

Roland

Well-Known Member
Join
Jul 30, 2019
Messages
74
Age
60
I bought my spark 15 months ago, have a motorola g6plus ( brilliant screen)on android 9 and never had problems. I think djigo4 around that time was 4.3.10
Since then android 10 is the actual operating system
A few months ago I noticed that active track in litchi was completely impossible , continuous losing my object while gimbal was going up and down.
image on the phone choppy and low resolution , range normally about 2400 m became difficult with loss of image .
Active track in djigo4 was much better but not as good as before. but also poor image and range
on the mavic forum I saw a complaint about same problems back in 2018 . Solution then was downgrade to an earlier version.
So I looked at
DJI GO 4-For drones since P4 APKs - APKMirror
and guess what there were 2 updates in march and may around the time I got troubles.
I downgraded to 4.3.10 and everything is fine even in Litchi.
My 2 cents : If android is upgrading , Dji has to upgrade too . But if youre phone isn't upgraded as mine is , one possibly can create a conflict .
Try win 10 software on a win 7 pc , big chance it won't work.
So , I suggest downgrade your spark to at least 4.3.25 or less, put a decent SD card in your spark which supports 1080x1920 and try again
 

az erik

Active Member
Join
May 1, 2020
Messages
30
Age
45
I fly a small area around 100yardsx 100 yards kind of often. It's city and has a ton of wifi in the area. I've switch channels all over and it still happens there. Yesterday I flew staight up in the middle of that area about 60 ft and hovered, after about 10 seconds it dropped. Then came back. From that point on controls were flakey. I had the antenneas pointed at me with the blade facing the spark.

I have also flow out in the middle of nowhere 5 to 10 miles from anything. and 50% of the time I lost the signal. My go cable doesn't seem to do what I thought it was supposed to as I still have to connect to the RC with my phone and if signal is lost it appears to be the remote, I've caught sometimes the light goes red.

Another couple people have noted that the latest IOS .30 disconnects on them a lot. I (we) sadly don't have the option of downgrading as it's gone from the store. If I could find a ID for it I could try poking around on torrents or something.

RTH doesn't kick in, Usually the signal is lost for a couple seconds. So far nothing more than 5 seconds or so.
 

MannyCAM2001

Well-Known Member
Join
Jan 29, 2018
Messages
524
Age
66
At this point it really does sound like a software issue. A shame you don’t have access to an ios device just to make sure it’s software related.
 

az erik

Active Member
Join
May 1, 2020
Messages
30
Age
45
I have LOTS of IOS devices but only access to the 4.3.37 app

Can I fly with just the remote (yeah that's a complete noob question which I'm sure the answer is "yes sure you can") without it possibly flying away on me if the signal is lost. I don't know if the phone gps set the RTH point and sends it up to the Spark.
 

jimlips

Well-Known Member
Join
Feb 12, 2019
Messages
129
Age
61
Loc
West Sacramento, CA
@az erik : what country are you in? I know that DJI lowers the wifi power output in some countries. And I'm assuming you have the two antennas on the RC adjusted perpendicular to the aircraft? They should NOT be pointed at the aircraft, as the signal comes off the sides of the antennas.
 

az erik

Active Member
Join
May 1, 2020
Messages
30
Age
45
I'm in the US, have done the calibrations as well. I'm not pointing the tips at the craft, I did pick up on that a while back.

What I find odd is that the recordings to the SD card are also getting messed up and choppy. I almost always take off with a fully battery and remote. But i don't turn off wifi on my phone as it still connects to the remote via wifi even with the OTG cable. I'm wondering it the remote is the culprit, but don't know how I'd look for that.

The log dir on my SD card is also empty.
 

az erik

Active Member
Join
May 1, 2020
Messages
30
Age
45
It appears I can get the CSV of the most recent flight that it dropped signal on when I was just hovering. Trying to figure out how to get that off my phone now.
 

Spark 317

Well known member with a Spark.
Premium Pilot
Join
Jul 10, 2017
Messages
4,623
Loc
Indiana, USA
But i don't turn off wifi on my phone as it still connects to the remote via wifi even with the OTG cable.

Turn OFF the WiFi on your device when using the OTG cable unless your WiFi is connected to another WiFi source such as home or a hot spot WiFi.

I fly with a mini4 and I make sure the WiFi is turned OFF when using the OTG cable.

Occasionally I'll be around home using the mini4 to update stuff using the home WiFi and forget to turn it off when finished which affects my flights due to the Spark sneaking in the mini4 and connecting, even when using the cable.

I assume the WiFi connection overrides or corrupts the cable input on an Apple device. 🤔

The footage on the SD card should not be affected as the Spark records directly to it.

Are you using a quality SD card with a good video capture rate?
 
  • Like
Reactions: Dragonfly Joe

Spark 317

Well known member with a Spark.
Premium Pilot
Join
Jul 10, 2017
Messages
4,623
Loc
Indiana, USA
It appears I can get the CSV of the most recent flight that it dropped signal on when I was just hovering. Trying to figure out how to get that off my phone now.

This site may help in retrieving and transferring the log(s).



You can then post a URL link of the results back here if you wish to have other members view the flight(s) and may be able to see something in the logs.
 

Tony-Spark

Member
Join
Apr 16, 2019
Messages
14
Age
75
Loc
Anacortes, WA
Web
www.electronic-supply.com
Hi all. I picked up a refurb spark about 2 months ago. Logged a few flights but from day one I lose signal to the bird.I used to think it was wifi interferance but I've switched channels all around with no luck as well.

I've always been on the latest firmware and IOS go4 app.I use an OTG cable pretty much every flight. I have noticed if I set the spark in flight mode with just my phone I have to rebind the remote. I've followed the start up procedure as I've read here. Spark, Remote, OTG into the phone then app. Strange thing is when I lose signal I seem to lose the recording on the card as well. When I see choppiness in the files on the phone I also see it in the card. Almost like the whole Spark is choking.

What could cause something like that? Bad or faulty unit? Can I find this somewhere in a log by chance from the Spark?
I find that I may lose signal if I fly without the controller connected via OTG cable in my area (there is a navy station a few miles away with a very strong radar) - but I don't have problems when using the controller. I mostly fly when I'm on extended trips through the deserts of Montana, Wyoming, Nevada and Oregon with no problems. I am wondering about the longevity of these batteries though - are they going to be available in the future. Who knows?
 

awacsnl

Well-Known Member
Join
Mar 6, 2018
Messages
139
Age
55
I have some thing to say to clear a few things, connection lost, or go crashes can have several causes.
First the spark don't need to upgrade the go4 app, change are only for the newest drones.
I follow the forums and the most stable version with OTG support is 4.1.15.
Run on android 4.4 and above, No android 10.
When you use an OTG cable, be sure to switch off wifi and bluetooth.
Start RC, Start Spark, wait untill Green light on RC, then connect OTG cable in RC. Start DJIgo4 app.
Look on app on top if you fly on 5.8 or 2.4ghz. You can change but do it with No otg cable, or with otg cable but you need a modified dji go4 4.1.15.
5.8 less interference on FPV video but less range. 2.4ghz far range but in a area with a lot of wifinetworks you can get a delay of your video FPV, or even a connection lost.
Solution for this is using more transmitting power using a modified go4 app with permanent Fcc power or a custom RC firmware with boost power(works also on litchi)
 

NOLADG

Active Member
Join
Nov 28, 2019
Messages
31
Age
50
RTH doesn't kick in, Usually the signal is lost for a couple seconds. So far nothing more than 5 seconds or so.
On a completely different thought: How is your OTG cable. I had a cable that was loosing connection on the RC side and would loose video feed and access through the DJI GO app. However the light on the RC would stay green. I replaced the cable with an adapter and that fixed the issue.

The feed on the SD card is probably a different issue. Like others have said make sure the rating on the SD card is high enough to handle the video and try a fresh formatting in the Spark.
 

awacsnl

Well-Known Member
Join
Mar 6, 2018
Messages
139
Age
55
yes, be aware to put the micro connection (OTG) the right way into the RC, a friend of mine, did it reverse with force and now he must buy a new RC, it was damage and didn't charge anymore. The connection green light is always green without or with an OTG cable.
If you switch of your wifi from your phone or tablet you then be sure you use the OTG connection instead of the wifi
 

az erik

Active Member
Join
May 1, 2020
Messages
30
Age
45
I was up at my place in the north this last weekend and needed to run the Spark around the top level of my cabin to check out some windows I might have issues with. I was having a heck of a time getting sat lock. I finally found a spot where I could get enough to take off. I took off and 1st stupid thing: thought I was taking a video, took a picture. Flew around the windows ever so closely, 3 ft away with a 5ish mph wind. And the remote lost signal. I finally had it happen long enough I noticed the red light on the remote. I wasn't flying with a OTG, and it was going to be my roof I'd crash into if something went wrong. The Spark hovered for about 15 seconds and the remote went green again. It was ;less than 15 feet away from me, however it was almost directly above my Airport Extreme 5g wifi. It came back online and I, stupid thing #2, clicked to stop taking the video I wasn't taking, and took another picture. Landed and looked at my phone and thought the video wasn't there due to the remote disconnect. Drove 200 miles home, pulled the SD card and, oh nice 2 pictures..

the remote antenna blades were pointed at the drone when it disconnected. They have almost always been pointed the correct way and it's almost always disconnected within 25ft of me. It's on 5.8 and I changed the channel to 161 and 149 with no luck. I'm wondering if theres a way to force reflash the remote?

Side note, the Go software issue may or may not be related at all, but others have noted a lot of disconnects with the latest, and sadly that's all I have access to. The mod4 just doesn't run on my Galaxy Tab, neither does Litchi
 

awacsnl

Well-Known Member
Join
Mar 6, 2018
Messages
139
Age
55
Red light on your RC? you fly on your Phone only, range is about 50 mtr.
Rebind your RC again, start RC, start spark. Then hold battery of your Spark 3 second till you heard beep, then hold pause, fn and special button under the photo button untill you heard rhe RC beeping, put RC next to spark, wait untill Green light. Open dji go app and connect your wifi.
Please use OTG cable, then you can switch to 2.4 gig for great range, or 5.8 for close by but stable connection
 

az erik

Active Member
Join
May 1, 2020
Messages
30
Age
45
Yeah. I've caught the remote going red quite often. I tried flying with my phone only (which was what I was planning on doing in Hawaii in a couple months, but that's up in the air now) and it does drop with just that as well. Stops and hovers and then recovers. I jumped all over the 5.8 spectrum with the same results. When I was flying with the OTG cable and it would drop the phone would go 'offline' for a couple seconds.

I've rebound it a few times as any time I mess with holding the battery button down for 3, or 6 seconds (which I thought was 'switching' between rc mode and phone mode) I end up having to fully rebind via the method you mentioned.

I'm going to search and reflash everything a couple times. It came from DJI with the latest firmware.
 

awacsnl

Well-Known Member
Join
Mar 6, 2018
Messages
139
Age
55
oke, also if you can use the 4.1.15 mod version of djigo4 app, you can easy change with an OTG cable to 2.4 or 5.8 gHZ wifi , also you have FCC power and the mavic pro stuff
 

New Threads

Forum statistics

Threads
13,103
Messages
109,115
Members
16,530
Latest member
Sean_OL