Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Spark crashes on takeoff

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
Hi all,

When I try to takeoff, my spark goes up as usual but when I push the throttle it has a hard time pulling up and ends up bouncing on the ground.
Needless to say I broke a few propeller and some new scratches to the spark's body.
I've been having this issue since day but it happened occasionally and now it happens almost every time.
I know this has been an issue for some other owners and I found some posts online but I could not find any solution.
If someone had this issue before and found a way to fix it, i'll be grateful.

Thanks.
 

pmshop

Spark Pilot Guru
Premium Pilot
Join
Oct 6, 2017
Messages
1,838
Age
52
Loc
Fredericksburg, Texas, USA
Web
www.youtube.com
Hi all,

When I try to takeoff, my spark goes up as usual but when I push the throttle it has a hard time pulling up and ends up bouncing on the ground.
Needless to say I broke a few propeller and some new scratches to the spark's body.
I've been having this issue since day but it happened occasionally and now it happens almost every time.
I know this has been an issue for some other owners and I found some posts online but I could not find any solution.
If someone had this issue before and found a way to fix it, i'll be grateful.

Thanks.
I hate to say I have never heard of this issue before and sounds like an issue to be resolved with DJI service.

Others may suggest to check and see if the propellers are installed properly but they really are foolproof & cannot be installed incorrectly.
 
  • Like
Reactions: Highflyer and Ishay

Saigondroner

Active Member
Join
May 12, 2019
Messages
31
Age
50
Hi all,

When I try to takeoff, my spark goes up as usual but when I push the throttle it has a hard time pulling up and ends up bouncing on the ground.
Needless to say I broke a few propeller and some new scratches to the spark's body.
I've been having this issue since day but it happened occasionally and now it happens almost every time.
I know this has been an issue for some other owners and I found some posts online but I could not find any solution.
If someone had this issue before and found a way to fix it, i'll be grateful.

Thanks.
Please post your logs...my guess is you took off in a new location, and the Spark had compass interference. There is no way to speculate further without the flight logs.
 
  • Like
Reactions: Ishay and pmshop

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
Please post your logs...my guess is you took off in a new location, and the Spark had compass interference. There is no way to speculate further without the flight logs.
It’s not a new place.
I got the logs from the black box tab in the DJI assistant 2 and I could not open them.
I’ll upload them when I get home.
 

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
If you are getting the dreaded Spark hop, then it wont even show in the logs. Is this similar to what its doing?
Exactly the same!
I saw in a post that it might be motor related problem but I couldn’t find something wrong with the motors.
 

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
I hate to say I have never heard of this issue before and sounds like an issue to be resolved with DJI service.

Others may suggest to check and see if the propellers are installed properly but they really are foolproof & cannot be installed incorrectly.
I have a lot of propellers and I tried them all so it’s not that.
 
  • Like
Reactions: pmshop

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
I suggest you connect your spark to DJI assistant 2 on the computer and reflash the firmware for your version
Tried that a few times with older and newer versions.
Tried calibrating everything. I’m pretty sure it’s a hardware issue. If I could only find the faulty hardware I’ll change it myself.
 

sv1000spilot

Member
Join
Jan 14, 2019
Messages
6
Age
54
My spark seems to do the same, but only occasionally and that seems to be if I take off using controller. If I use launch button on phone it seems to be ok..??
I now do all launches using screen launch button, then leave it hovering for about 30-45sec to stabilise before using the controller.
 

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
My spark seems to do the same, but only occasionally and that seems to be if I take off using controller. If I use launch button on phone it seems to be ok..??
I now do all launches using screen launch button, then leave it hovering for about 30-45sec to stabilise before using the controller.
Mine used to do it occasionally but now it does it almost every single time no matter how I take off.
 

Tentoes

Well-Known Member
Join
Jun 5, 2019
Messages
122
Loc
Oklahoma USA
A guy with a similar issue noticed it stopped when he changed the SD card. He thought the old sd card was too slow. I've always been curious if this is actually a thing.
 

graywoulf

The older I get, the better I was.
Premium Pilot
Join
Mar 30, 2018
Messages
903
Age
63
Loc
Millers Creek, NC
A guy with a similar issue noticed it stopped when he changed the SD card. He thought the old sd card was too slow. I've always been curious if this is actually a thing.
When I first got my Spark, I had bought an Micro SD card on eBay that turned out to be a fake. It made my Spark go crazy with random blinking lights and the cooling fan was going off and on. When I replaced the SD card, it worked as it should. Only use the recommended SD cards is the safest bet.
 
  • Wow
Reactions: DaysOfNoah

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
When I first got my Spark, I had bought an Micro SD card on eBay that turned out to be a fake. It made my Spark go crazy with random blinking lights and the cooling fan was going off and on. When I replaced the SD card, it worked as it should. Only use the recommended SD cards is the safest bet.
Thanks but Tried that as well with or without SD card
 
Join
Sep 15, 2018
Messages
13
Age
100
Take a look at the cell graph. At 23 seconds two cells drop voltage while the third gained a lot of voltage followed by 43 seconds of data loss. It happens again a dozen times.
Try another battery.
 

Ishay

Member
Join
Jun 22, 2019
Messages
20
Age
34
Take a look at the cell graph. At 23 seconds two cells drop voltage while the third gained a lot of voltage followed by 43 seconds of data loss. It happens again a dozen times.
Try another battery.
I have 4 batteries and it happens on all.
Where did you upload it to see the voltages?
 

RJB1

Member
Join
Jul 4, 2019
Messages
16
Age
56
I have 4 batteries and it happens on all.
Where did you upload it to see the voltages?
I feel for ya, this does seem to be the exact problem I've had, and every time I bring it up, I get the same answers from everyone. Try this, try that, try this. It's so frustrating because you can't ever truly replicate the problem. You try one of those things and yes it worked problem solved, only to find it comes back two flights later, so then you try something else. Yes it worked, only to have it come back again 4 flights later. In a way I'm glad to hear someone else is having the same problem, it was driving me mad that I seemed to be the only one having it to this extent. And since its now out of warranty DJI couldn't care less. "send it to our service center" is all they will say, but the posts I've read about their service center doesn't give you any confidence that they actually do anything to fix the drones, they just take them apart and then tell you you need a new one and since you have no warranty you are paying for everything. I can't even get DJI to admit that their "service center" has a real person working in it. They refuse to give me a local number to talk to anyone there.
 

RJB1

Member
Join
Jul 4, 2019
Messages
16
Age
56
My spark seems to do the same, but only occasionally and that seems to be if I take off using controller. If I use launch button on phone it seems to be ok..??
I now do all launches using screen launch button, then leave it hovering for about 30-45sec to stabilise before using the controller.
Strangely there is another video about the spark hop and he says the fix is to NOT take off with the phone app, but only take off with the controller. I use to take off with the app, because I saw the video and thought that would fix it. I did a whole reset of everything and it did fix it for a while, but then it started happening again. I think it's a hardware issue maybe in the IMU or sensor that is having fluctuations.

 
  • Like
Reactions: tmgrood

SaigonDude

Well-Known Member
Join
May 3, 2019
Messages
49
Age
51
Flight log added
sigondroner


I took a look at your log, I hate to tell you, but it looks like you took off before obtaining any GPS lock at all.

After 6 seconds 4 satellites registered, and ATTI mode started when it dropped to 3, but recovered.

From 1:15-1:44 you completely lost radio control, and the AC might have learned its position, but didn’t know where the HP was. Fortunately, your compass was working. The AC was probably drifting, and radio signal came back.

A few tips:

1. Wait to fly until the Home Point is recorded. Set your mobile volume high. DJI will tell you.

2. Do NOT use RTH/AutoLand if you are having problems. Land manually.

3. Record you Home Point


Safe flying!
 
  • Like
Reactions: tmgrood and Andro

New Threads

Forum statistics

Threads
10,889
Messages
89,837
Members
14,886
Latest member
rvlahos