Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

No obstacle avoidance without any warnings

ChristoffB

Well-Known Member
Join
Jan 14, 2019
Messages
61
Age
32
Loc
South Africa
This weekend a new problem emerged.

Normal procedure for me would be to hand-launch, take spark off gesture mode, fly, take photos, switch to sport mode and back etc. When I'm done I'll bring the spark back, fly towards myself until the obstacle avoidance kicks in and it doesn't' come closer, then approach the spark, hold my hand under it and force land by pushing the throttle all the way down.

This weekend however, on numerous flights (but not all) there was no obstacle avoidance when I brought the spark back (not in sport mode). Putting my hand underneath and throttling down did not initiate landing. Funny enough when I then took my hand away auto landing was initiated.

By looking at Airdata, on flights where the landing sequence was 'normal' the notification reads "Mode changed to Confirm_Landing ". The instances where the forced hand-landing did not work the notification reads "Mode changed to AutoLanding ".

There were no notifications of any sensor failures.

Anyone have any idea what is going on?
 

Jim Smith

Member
Join
Jun 1, 2018
Messages
10
Age
38
I have been having troubles with the altimeter lately as well. Mine does not typically detect the ground and would slam into it if I were not manually controlling it. I also noticed that if I initiate a Litchi waypoint mission it now assumes it is at 0 feet altitude when it start the mission. If it is already 200ft off the ground it will go up to 600ft. This started at some point this summer.
 

New Threads

Forum statistics

Threads
11,293
Messages
92,533
Members
15,230
Latest member
GG Teach