Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Which is the correct a to use for android

Joined
May 17, 2018
Messages
1
Likes
0
Age
61
#1
I have downloaded both dji go apps. When I go to connect neither drop down menu lists the advanced 3 drone therefore it won't connect. So where do I download the correct app to use for my advanced 3 drone?
 

Sparkz71au

Active Member
Joined
Feb 8, 2018
Messages
41
Likes
8
Age
46
#2
I have downloaded both dji go apps. When I go to connect neither drop down menu lists the advanced 3 drone therefore it won't connect. So where do I download the correct app to use for my advanced 3 drone?
Are you referring to the Phantom 3 Advance? Maybe you are in the wrong forum/site as it's not a DJI Spark?
Anyway, you if you need the Android version of DJI Go before P4 - https://play.google.com/store/apps/details?id=dji.pilot .... Otherwise DJI GO on the App Store

Look for all the information at Phantom 3 Advanced - Specs, FAQ, Tutorials, Downloads and DJI GO - DJI .

"Confuseduser" - did you connect your DJI Go android/ios device to the remote or aircraft Wi-Fi? Is the remote connecting to the P3A or do they need pairing.
This is a Spark forum so I can only guess.... Try a general DJI forum to ask your question?
 

New Threads

Forum statistics

Threads
6,720
Messages
56,594
Members
10,299
Latest member
DJIVik16