Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Ce to fcc Spark

grim101

New Member
Join
Apr 14, 2019
Messages
4
Age
31
I live in South Africa with my DJI Spark.

I get 350m the signal drops to 50%.

Flying on Ipad air 2.

I know I am on CE mode because it shows 13 channels.

I tried the hack with connecting to an android phone with a gps fooler (floater). It shows 11 channels on the android phone.

I then connect to the Ipad while its on and it shows 11 channels there too.

As soon as I power off the drone and change the battery and power it on again it does not ask anything about wifi settings and returns to 13 channels(CE)

Any help.
 

Paul215

Well-Known Member
Join
Nov 6, 2018
Messages
107
Age
27
Loc
Germany
I have the same problem when I switch between my androidphone and my iPad air. No pop-up with the "Cancel-Question"..... Do you have the problem when just using your android device? I don't use my ipad anymore because this reason. Hope for some useful answers, too.
 

grim101

New Member
Join
Apr 14, 2019
Messages
4
Age
31
The same problem.

As soon as I connect ipad its back to CE mode.

And I bought a Ipad just because of everyone saying that android gives trouble.
 

PopUnoNkoK

New Member
Join
Mar 23, 2019
Messages
2
Age
39
Well its the same for me. But I dont think it has anything to do with Android vs Apple. I did the "Fake GPS" routine and got into FCC mode (11 channels). I did this inside so that my Spark did not get any GPS location. But as soon as I got outside to fly It whent back to CE mode with 13 channels without asking and therefore i could not stay in FCC mode.
I did this all with the Android phone that I fly with. (Without any trouble btw).

Paul215 Are you managing to stay in FCC mode when you are just using your Android device?
 

Paul215

Well-Known Member
Join
Nov 6, 2018
Messages
107
Age
27
Loc
Germany
Paul215 Are you managing to stay in FCC mode when you are just using your Android device?
For some flights, yes. But then suddenly I'm back in CE mode without any message. I think this a problem from one of the last updates. The problems started around new year. Before that I stayed half a year in FCC mode without any problems.
 

lmel2005

Well-Known Member
Join
May 15, 2018
Messages
651
Age
61
It would be useful to report software versions (firmware, go4 app, OS), because there are no issues related to FCC hack, reported until now.
 
  • Like
Reactions: mko64

Pixies Channel

Well-Known Member
Join
May 27, 2018
Messages
115
Age
47
I have never had a problem with using the Floater app and I also use Android, Never have used an apple Ipad so I can't help you on that one. Do you have your Bluetooth switched off, Maybe that can help?
 
  • Like
Reactions: Paul215

slashster

New Member
Join
Mar 8, 2019
Messages
1
Age
47
Personally i'd assume that using FFC mode in CE mode countries would be an excuse for DJI to void youre DJI warranty or extended warranty if you have a fly away etc in FFC mode without youre countries approved drone licence.So personally i use Android with the DJI Go4 Modd 2.0 App which is set to FFC mode has more flight options for Spark like Mavic Pro also uses Google Maps(full version Mod 2.0 app) plus works perfectly with OTG cable.And yes i prefer to use FFC mode because of the safer high DB gain that does not dropout within CE limits like it does when set to CE mode.No need for Floater app when using Andriod with the DJI Go4 Modd 2.0 App. What you do is up to you.

 
Last edited:

Raoul

Member
Join
May 16, 2019
Messages
9
Age
32
Loc
Italy
Hello Grim101,
I've been using my Spark in FCC mode with an iPad Mini for over a year and I've never had your problem. Every time I run the app (Go4 or Litchi is the same thing) I get a popup asking me to change the transmission setting and I promptly cancel the request.

10238

Your problem may be caused by some outdated software. These are my working conditions:

iPad Mini 4
iOS 12.3.1
DJI Go 4 - 4.3.17
Litchi - 2.6.5
Spark - 01.00.1000
RC - 01.00.0600

I hope this can help you.
 
  • Like
Reactions: Oitar and Paul215

Spark-PK77

New Member
Join
Jun 11, 2019
Messages
2
Age
42
I have tried the floater method and it works for about 5 seconds before the dji app seems to override it and set it back to CE
 

nilanjan118

Well-Known Member
Join
Oct 31, 2018
Messages
616
Loc
Japan
I have tried the floater method and it works for about 5 seconds before the dji app seems to override it and set it back to CE
Could you give some more details please?
Please note that while setting up the fake location via floater app, your RC and phone should be connected via WiFi. Once the RC makes the switch to FCC mode and establishes the connection again, turn off everything and turn on again. Are you getting the prompt to switch connection due to different geographical location now? You are supposed to select cancel here.
If all of the above is true, you can start using OTG cable again. But make sure to select cancel each time you start the Go4 app and you are asked to switch connection due to different geographical location.
 
  • Like
Reactions: Spark-PK77

nilanjan118

Well-Known Member
Join
Oct 31, 2018
Messages
616
Loc
Japan
Personally i'd assume that using FFC mode in CE mode countries would be an excuse for DJI to void youre DJI warranty or extended warranty if you have a fly away etc in FFC mode without youre countries approved drone licence.So personally i use Android with the DJI Go4 Modd 2.0 App which is set to FFC mode has more flight options for Spark like Mavic Pro also uses Google Maps(full version Mod 2.0 app) plus works perfectly with OTG cable.And yes i prefer to use FFC mode because of the safer high DB gain that does not dropout within CE limits like it does when set to CE mode.No need for Floater app when using Andriod with the DJI Go4 Modd 2.0 App. What you do is up to you.

How does using a hacked app or moded app as you say not void the warranty?
 

Spark-PK77

New Member
Join
Jun 11, 2019
Messages
2
Age
42
Could you give some more details please?
Please note that while setting up the fake location via floater app, your RC and phone should be connected via WiFi. Once the RC makes the switch to FCC mode and establishes the connection again, turn off everything and turn on again. Are you getting the prompt to switch connection due to different geographical location now? You are supposed to select cancel here.
If all of the above is true, you can start using OTG cable again. But make sure to select cancel each time you start the Go4 app and you are asked to switch connection due to different geographical location.
Hi thanks for the info, it finally worked after trying several times. It's as though it took a few times to trick the dji app into thinking I was in the location that floater was putting me at, but eventually it stayed that way and I bow get the message each time I.statt it and press cancel. Thank you
 
  • Like
Reactions: nilanjan118

New Threads

Forum statistics

Threads
10,591
Messages
87,837
Members
14,619
Latest member
Frankiep