Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Litchi Issues....


Well-Known Member
Dec 3, 2017
Ok so I was attempting to fly a proven Litchi Mission with my Spark but ran into a couple of issues... This is a mission that I devised a couple of years ago and have flown many times with both my Spark and Mavic Air. However, this time the Litchi app began throwing these alerts at me every time I loaded and then tried to start the mission. After multiple attempts, I decided to bring it back in and try a fresh battery and re-calibrate the compass with no luck again. I then brought the Spark back and the tried the same mission with my Mavic Air which I had no issues whatsoever. I added a couple of screen shots to display what I was seeing... As you can see, I had 10 satellites but the display was saying OPTI and said No GPS lock ( which was weird because it kept bouncing between GPS lock and OPTI). The other pick had a battery power limit warning and low drone mobility. Anyone have any ideas as to what the Sparks problem may be?


  • Screenshot_20240207-161946.png
    4 MB · Views: 5
  • Screenshot_20240207-161957.png
    4.5 MB · Views: 5
Okay so I took both my mavic air and my spark to a different location. The mavic 2 different Litchi missions multiple times with out any issues. So I put the spark up and it made it around 200 ft away and stopped dead in it's tracks. Looks like it's not finding enough satellites. Took off with 11 found... Dropped to only 9 and then stopped. Any idea of what to do to possibly boost or reset the sat/gps?
Same issue with djigo4?
If so, i should say, it is in the spark
Indeed, same Satellite count usingDJIGO4... But it doesn't interfere with the manual operation of the drone. It flies just fine with the 8-10 Satellites using the DJI GO4 it seems like once it drops to 10 or below, the waypoint mission just stops. Here is airdata screen shots from the latest flight where this happened. Screenshots show the original flight path, signal strength during flight and then the GPS signal during the flight. When it's red, it usually 9 or below. 10 or better is usually orange. 14 or better is green.


  • Screenshot_20240212-184511.png
    1.5 MB · Views: 2
  • Screenshot_20240212-184543.png
    1.7 MB · Views: 2
  • Screenshot_20240212-184529.png
    1.6 MB · Views: 2
GPS receiver or bad contact somewhere in gps circuit.
Compass, IMU and position sensors can be calibrated but a GPS works yes or not.
You can try a firmware reset
My 2 cents

New Posts

Members online

Forum statistics

Latest member