Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Return To Home Speed > Outbound Speed

Join
Jul 9, 2017
Messages
3
Age
61
Loc
Florida, United States of America
I took a couple of flights today (no wind) and my outbound speed was about 6 MPH. When I selected RTH the speed went to 20 MPH. The Spark was not in Beginner or Tripod mode. I am using a remote wifi hookup. The wind was less than 5 MPH.

Having owned a Mavic this doesn't seem right ?
 

SparkCodingDummy

New Member
Join
Feb 26, 2018
Messages
3
Age
41
You might also need to make an adjustment in the "Remote Controller Settings" section of the app once you've connected to your drone. There's also slider for "Max Speed Flight Settings" that for me was set to the minimum. I bumped this up, and was then able to get 14mph in sport mode.



For those that are getting ~30mph:
I've turned off all obstacle detection, turned on sport mode, adjusted the settings above and consistently seem to be limited to 14mph, but I get 22mph in RTH. Any other tips?
 

Teq

Active Member
Join
Jan 25, 2018
Messages
36
Age
47
20mph for RTH is normal. 6 mph is also normal with forward collision sensing on. Turn off obstacle detection and you should be able to get about 12 mph normal and ~30 in sport mode. Oh, and make sure you have beginner mode turned off.
 

Rafa7

Well-Known Member
Join
Feb 21, 2018
Messages
337
Loc
Georgia USA
Some setting still not right with your setup, keep digging and you'll find it. Are you using Android or IOS to fly?
I found the sweep spot for my Spark and just over the weekend I was doing 33.7 mph top speed with my Spark (with some tail wind) and a return speed of 32.1 mph. The Spark is a 'little monster' and that was beautiful ...then you see it applying the breaks for stopping, WOW! ...I need more of this, every day... : -)
 

ery887

Member
Join
Feb 12, 2018
Messages
21
Age
31
Thats weird...this is my speed in sport mode and normal

P/S: during RTH push the right joystick stick forward for max speedScreenshot_2018-02-27-15-42-33-11.jpgScreenshot_2018-02-27-15-40-57-95.jpgScreenshot_2018-02-27-15-40-30-57.jpg
 

SparkCodingDummy

New Member
Join
Feb 26, 2018
Messages
3
Age
41
Figured out the issue with my limited speed tonight thanks to this thread.

I still wasn't seeing speeds of 30mph. I was getting ~12-14mph in both Sport and regular mode (this was with the combination of obstacle avoidance disabled and max flight speed settings to the far right)

When I enabled sport mode on the RC, I saw a brief warning popup that said:
"Intelligent Flight Modes have not been enabled. Enable this option in Main Controller Settings if needed."
See below for an example
2018-02-26_22_01_53-edit.jpg

Turns out it was prior use of an OTG cable and dorking up some settings that are not visible without the cable. See this other thread for the fix.
 
Last edited:

New Threads

Forum statistics

Threads
11,878
Messages
99,198
Members
15,683
Latest member
McQuizzle