Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

"Switch WLAN Settings" Dialog after Warranty Replacement

Dodge DeBoulet

Well-Known Member
Join
Dec 27, 2018
Messages
221
Loc
Maine
I finally got the opportunity to go flying yesterday after replacement of the Spark I bought back in December (the original had a defective USB port and I could not connect to it via DJI Assistant 2, nor would it show up as a storage device on my PC so that I could download pictures). I suspected there might be a bit of setup required, but wasn't prepared for the torturous route to the eventual solution. Posting that here in case someone else runs into the same issue ...

The first step after receiving the new Spark was to re-link it to my controller. That was pretty straightforward ... turn the controller and Spark on and wait for them to boot up. On the Spark, press the battery button for 6 seconds and release it when you hear a single beep. Now, press and hold the Pause, Fn and right custom button (below thee still shot button) on the controller. The controller will emit a fast beeping, and the indicator light on it will flash green. Within 10-15 seconds, the beeping will stop and the indicator will be steady green. The Spark will also change its flashing light pattern to indicate that it's connected.

Connect the phone and the RC (I use an OTG cable for this), then Open DJI GO 4. You'll see a few messages flash on the display indicating firmware status and/or the need to update the safe flight database. Once that completes, if you're lucky, you'll get a "GO FLY" indicator and you're good to go.

I didn't, though. I got this instead:
9912

Of course, I wasn't in a different country ... but every single time I turned my controller and drone on, this would pop up. Pressing "OK" would disconnect the controller from the Spark.

I could usually turn just the spark off and on again, and it would connect OK. Not convenient, but at least I could fly. But my original Spark didn't demand this much finagling, so I figured there must be a solution (even if it meant returning the new Spark for service). So after a bit of googling, I came across a thread on the DJI forum with half-a-dozen different suggestions for solving this issue ... resync the controller to the spark, fully reset the controller and spark and resync, uninstall/reinstall the DJI GO 4 app, clear the DJI GO 4 app's cache and data ... none of these had any effect. I also tried everything with a different phone/tablet with the exact same results.

The entirely counter-intuitive solution, found on page 2 of that thread, was to connect the phone directly to the spark via wi-fi, with the RC turned off. This apparently has the necessary mojo to convince the Spark of its current location, and made that "Switch WLAN settings" annoyance go away regardless of the connection method used. I was subsequently successful in connecting my phone to the RC with the OTG cable, and have had no further issues getting my Spark in the air using the RC with multiple attempts.
 

Attachments

pmshop

Spark Pilot Guru
Premium Pilot
Join
Oct 6, 2017
Messages
1,853
Age
52
Loc
Fredericksburg, Texas, USA
Web
www.youtube.com
Never had an issue with my Sparks received from DJI repair.
Even on the brand new Spark I got that message.
Just waited for the switch, about 10 seconds and all was well.
It comes in CE mode by default - lesser of the two modes to be safe.
Once it sees where you are, it automatically switches.

But relating to your fix, I wonder if this can be resolved with non GPS tablets/ iPads???
 

New Threads

Forum statistics

Threads
10,914
Messages
89,987
Members
14,902
Latest member
Spectre68