Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

2.4GHz & 5.8GHz (distance complaint)

AF_Flyer

Active Member
Join
Jun 18, 2017
Messages
41
Loc
Crestview, FL
While flying today I losing signal and my controller switched back & forth between 2.4GHz & 5.8GHz. I wasn't that far away & didn't see much difference in reception.

I really like the Spark so far but one of my biggest issues is that I can't fly it more than about 1100 feet before it cuts out. Every time I fly it's set to 5.8GHz but I can't see where to change it, if it's even possible. If I could get the range of even half of what DJI claims I would be happy.

All my flying is mainly in open areas so there shouldn't be much if any interference. Any ideas or things I could try to help?
 

SafariMan

Member
Join
Jun 20, 2017
Messages
16
Age
56
I guess you are using an iOS device. Try to press the power button and hold it down till you hear 3 beeps. That should put your spark on the 2.4GHZ and should stay likewise till you turn off the drone.
 

His415

Well-Known Member
Join
Jul 12, 2017
Messages
436
Age
38
It took me a hot min to figure out how to change it too. Once you are at the screen with channel list and signal strengths, you can swap to 2.4 and then click a channel number below and it will prompt you about restarting wifi.
 

regdawg

Well-Known Member
Join
Jul 16, 2017
Messages
81
Age
41
Which is better..the 2.4ghz or 5ghz? I've noticed each time I've flown its on the 5.8ghz frequency. I'm using the RC. I've done nothing to adjust anything.
 

AF_Flyer

Active Member
Join
Jun 18, 2017
Messages
41
Loc
Crestview, FL
I guess you are using an iOS device. Try to press the power button and hold it down till you hear 3 beeps. That should put your spark on the 2.4GHZ and should stay likewise till you turn off the drone.
No I have an Android and holding the button down did nothing for me.
 

AF_Flyer

Active Member
Join
Jun 18, 2017
Messages
41
Loc
Crestview, FL
It took me a hot min to figure out how to change it too. Once you are at the screen with channel list and signal strengths, you can swap to 2.4 and then click a channel number below and it will prompt you about restarting wifi.
I tried this but it doesn't give me the 2.4 option.
 

His415

Well-Known Member
Join
Jul 12, 2017
Messages
436
Age
38
I just tried it out and it took a min for the 2.4 option to show up. I was using the RC with no otc cable. Almost like it took a min for the 2.4 to initialize. I would say it was 30-45s IMG_6768.jpg
 

Spark-Dane

New Member
Join
Aug 2, 2017
Messages
4
Age
53
Hello all, not sure if this is already old news. I saw the discussion and i figured the issue is basically related to your phone connection (at least where i'm from).
I have a phone only supporting 2.4 ghz. If I try to change the wifi connection in dji go 4 app (the connection between the remote and the drone) i cannot connect my phone to the remote. Makes sense because it's already taken by the connection to the spark. However if I take my iphone 6 which supports 5ghz band i can change the connection from the remote to the spark to 2.4ghz. I then loose my connection from the phone to the remote by wifi. I then go to my phones settings and connects again to the remote (which then is 5ghz band), i connect again to the remote and all is then good.
I dont have the OTG cable but I suppose I can do the same trick using the cable and force the connection from the remote to the spark to use 2.4 and then get a better connection long distance.
Does it make sense? .. anyway works for me.
 

Dronason

Well-Known Member
Premium Pilot
Join
Jun 28, 2017
Messages
1,136
Loc
Switzerland
Hello all, not sure if this is already old news. I saw the discussion and i figured the issue is basically related to your phone connection (at least where i'm from).
I have a phone only supporting 2.4 ghz. If I try to change the wifi connection in dji go 4 app (the connection between the remote and the drone) i cannot connect my phone to the remote. Makes sense because it's already taken by the connection to the spark. However if I take my iphone 6 which supports 5ghz band i can change the connection from the remote to the spark to 2.4ghz. I then loose my connection from the phone to the remote by wifi. I then go to my phones settings and connects again to the remote (which then is 5ghz band), i connect again to the remote and all is then good.
I dont have the OTG cable but I suppose I can do the same trick using the cable and force the connection from the remote to the spark to use 2.4 and then get a better connection long distance.
Does it make sense? .. anyway works for me.
No, if you use OTG cable, you have first to be connected by Wifi to select the band you want to use and then connected the cable / disable wifi. When connected by cable, you cannot select the band, only by wifi.
 

Dronason

Well-Known Member
Premium Pilot
Join
Jun 28, 2017
Messages
1,136
Loc
Switzerland
While flying today I losing signal and my controller switched back & forth between 2.4GHz & 5.8GHz. I wasn't that far away & didn't see much difference in reception.

I really like the Spark so far but one of my biggest issues is that I can't fly it more than about 1100 feet before it cuts out. Every time I fly it's set to 5.8GHz but I can't see where to change it, if it's even possible. If I could get the range of even half of what DJI claims I would be happy.

All my flying is mainly in open areas so there shouldn't be much if any interference. Any ideas or things I could try to help?
If you have any bluetooth device active around you, you should turn them off or putting them in airplane mode. This generate a lot of disturbance on 2.4G.
Don't forget that the range indicated by DJI is measured in ideal conditions where there is no interference sources around you and the Spark at 2.4G and 5.8G.
Wifi link for the Spark is very sensitive to wifi near you and near the Spark.
 

Dronason

Well-Known Member
Premium Pilot
Join
Jun 28, 2017
Messages
1,136
Loc
Switzerland
Which is better..the 2.4ghz or 5ghz? I've noticed each time I've flown its on the 5.8ghz frequency. I'm using the RC. I've done nothing to adjust anything.
If it starts at 5.8G, it means that the 2.4G band is used by some other wifi or bluetooth devices. So the link from the phone to the RC will have to use the 2.4G band.
2.4G give normally more distance from radio point if view. In some area, it will be 5.8G that will work the best if no nearby wifi use 5.8G band.
 

Dronason

Well-Known Member
Premium Pilot
Join
Jun 28, 2017
Messages
1,136
Loc
Switzerland
I guess you are using an iOS device. Try to press the power button and hold it down till you hear 3 beeps. That should put your spark on the 2.4GHZ and should stay likewise till you turn off the drone.
IOS devices can handle the 5.8G channels (149-165) used by the Spark. Many android phones don't give access to these wifi channels in Europe as they are dedicated to short range devices (in europe). At least Samsung S8 handle them correctly as an iPhone would do.
This tip of pressing the battery to force the Spark operating at 2.4G is only valid for direct phone connection to the Spark (without RC). If you use it, then you will have to relink your RC to the Spark.
 

tonyt76

Active Member
Join
Jun 16, 2017
Messages
37
I guess you are using an iOS device. Try to press the power button and hold it down till you hear 3 beeps. That should put your spark on the 2.4GHZ and should stay likewise till you turn off the drone.
Power button on the controller/drone?
 

msinger

DJI Drone Expert
Approved Vendor
Premium Pilot
Join
May 27, 2017
Messages
2,841
Loc
Harrisburg, PA (US)
Web
www.Spark-Help.com

GoldenZippo

New Member
Join
Sep 9, 2017
Messages
2
Age
40
This discussion has a lot of great info. I was just wondering what kind of distance everyone averages in residential areas? I have a lot of above ground power lines by me and also noticed a few things in this thread I could be doing to possibly get a little more distance but almost 700m has been the furthest I can get using an otg cable before I lose connection & RTH. Thanks for all the helpful info, definitely going to make sure I'm in 2.4 before plugging in otg now (I was wondering how to check since no wifi shows up using otg thnxs) also just realized although flying in airplane mode I've been wearing my Fitbit the whole time.
 

New Threads

Members online

Forum statistics

Threads
11,929
Messages
99,781
Members
15,730
Latest member
shaunfnewhouse