Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

I am beside myself .....

Outdoorsfellar

New Member
Join
Jun 29, 2020
Messages
2
Age
59
I purchased my Spark just over a year ago along some others, of other brand. I used Litchi exclusively all this time with no problems & without using the OTG cable. I hadn't used the Spark since December & started to use it again just earlier this month. On my very first flight , I sent it on its mission & did not have reception for the return. It came in for it's programmed landing & then went straight up about 200 feet on it's own. It hoovered a bit & then came down right into a very tall tree. It stayed there for a number of days before falling out. I couldn't use it again & sent it back to DJI. I have the refresh program, so they they sent me a new Spark replacement.
Upon receiving this replacement, I had a very difficult time getting it to connect with the DJI Go 4. I eventually got it connected & also the Litchi app. On the very first flight, which was the same as before, it did exactly the same thing again ! No reception after take off& stuck right back in that tree again. It fell out a few days later, with no damage at least. I did play around & decided to use my OTG cable & had no problem with connection to either app .... BUT .... there is no Spark wifi it connects to. Once Litchi or DJI Go is loaded, it automatically connects just the same . All was well with my missions, BUT .... When I start my Litchi flight plan ... no matter where the Spark is hoovering & where my first waypoint is, the Spark will rise up backwards. It's like it has a mind of its own.. Even when I stop the mission, I still don't have control for a bit. It did hit some leaves of one tree this morning with no issue afterwards & then, just now, it flew up into the original tree from my earlier problems & came crashing down. When I start my missions, the starting waypoint is away from any trees, but they're like a magnet. There is some damage this time around with one of the motors. It's very tight & gets really hot.

Anyway, I can't understand why it'll fly backwards as it starts up. The first waypoint is always out front. Has anyone else expierienced this ?
 

NJSpark

Well-Known Member
Join
Jun 6, 2019
Messages
132
When you got the refresh spark did you do an imu calibration? Compass calibration?(compass might not be needed unless the app says so but i am not sure Litchi will alert you of this that is where Go4 might come in)
Before running did you test and confirm you can take off without issues (steady hover, etc)?
Have you just tried the GO4 app (leave Litchi out of the equation) and see if the AC flies correctly and steady?

Now since there is possible damage to the motor I would not fly it and fix it or have it fixed by DJI since flying with a bad motor will most likely cause other issues.

Hopefully some of these suggestions help. Keep us posted!
 
  • Like
Reactions: Spark 317

Outdoorsfellar

New Member
Join
Jun 29, 2020
Messages
2
Age
59
Hi and thank you for the reply. As I implied, the Spark flew ok with using both apps. I made sure there were no warnings using the DJI app beforehand as well. Calibrations were done as well. If I remember correctly, my original Spark would go backwards a bit before proceeding into the flight plan, but this time around its like it has a mind of its own for a bit. In regards to the motor, there's no way I can fly it now as it is.
 

RotorWash

Well-Known Member
Premium Pilot
Join
Jul 18, 2019
Messages
792
Age
53
Loc
P.E.I., Canada
I purchased my Spark just over a year ago along some others, of other brand. I used Litchi exclusively all this time with no problems & without using the OTG cable. I hadn't used the Spark since December & started to use it again just earlier this month. On my very first flight , I sent it on its mission & did not have reception for the return. It came in for it's programmed landing & then went straight up about 200 feet on it's own. It hoovered a bit & then came down right into a very tall tree. It stayed there for a number of days before falling out. I couldn't use it again & sent it back to DJI. I have the refresh program, so they they sent me a new Spark replacement.
Upon receiving this replacement, I had a very difficult time getting it to connect with the DJI Go 4. I eventually got it connected & also the Litchi app. On the very first flight, which was the same as before, it did exactly the same thing again ! No reception after take off& stuck right back in that tree again. It fell out a few days later, with no damage at least. I did play around & decided to use my OTG cable & had no problem with connection to either app .... BUT .... there is no Spark wifi it connects to. Once Litchi or DJI Go is loaded, it automatically connects just the same . All was well with my missions, BUT .... When I start my Litchi flight plan ... no matter where the Spark is hoovering & where my first waypoint is, the Spark will rise up backwards. It's like it has a mind of its own.. Even when I stop the mission, I still don't have control for a bit. It did hit some leaves of one tree this morning with no issue afterwards & then, just now, it flew up into the original tree from my earlier problems & came crashing down. When I start my missions, the starting waypoint is away from any trees, but they're like a magnet. There is some damage this time around with one of the motors. It's very tight & gets really hot.

Anyway, I can't understand why it'll fly backwards as it starts up. The first waypoint is always out front. Has anyone else expierienced this ?
This thread may address your motor issue. As for the Litchi issue, it may help to share your mission as well as your flight log (if privacy isn't a concern of course).
 

Roland

Well-Known Member
Join
Jul 30, 2019
Messages
74
Age
60
Did you try to do another mission far away from that tree ? In Litchi several settings are taken over from DJI GO4 . Gimbal speed can only be set in DJI go4 .If you use an OTG cable max height and return settings are taken from DJI GO4 IF you set RTH height 200 ft in DJIGO4 and 100ft in Litchi . It will return on the 200ft height you set with DJI GO 4 . In wifi mode this bug doesn't exist.
If You only have connection between RC and phone with OTG, reset your RC ( 9 sec. rule) Thereafter make connection in wifi ,password 12341234 close it and then again you can reuse OTG.
And as I found out a few days ago , in march and may DJI go4 updated to 4.3.36 . Since then tracking in Litchi was completely instable, poor image on the phone. DJI go 4 still did the job but not as usual.
I downgraded djigo4 to 4.3.13 and now everything seems to be ok again.
I lost 2 times control to my spark ( in orbit and follow) . It dissapeared to the north in ATTI . But after examining airdata . I took off with to less sattelites because of trees and or interference and maybe bad calibration . About calibration, removing props is more important as I ever tought . Put a spark on its side with props gives not the exactely 90° horizontal and vertical . Put some strong wind on it and spark can loose its perception and flip away.

BTW Not this long ago someone on the forum had a fly away just after starting a mission.

just my 2 cents
 

Kidroc

Well-Known Member
Join
Apr 24, 2018
Messages
82
Age
44
Something tells me you should stop uploading that mission or at least land it yourself I love my spark I had since the day it was released but i only use it at night vlos only it;s the best darn night flyer DJI has in my opinion.
 

RotorWash

Well-Known Member
Premium Pilot
Join
Jul 18, 2019
Messages
792
Age
53
Loc
P.E.I., Canada
Something tells me you should stop uploading that mission or at least land it yourself I love my spark I had since the day it was released but i only use it at night vlos only it;s the best darn night flyer DJI has in my opinion.
Love flying the Spark at night! Very relaxing and the day's stress melts away.
 

jimlips

Well-Known Member
Join
Feb 12, 2019
Messages
129
Age
61
Loc
West Sacramento, CA
I've run lots of missions on the Spark with no issue - I always "manually" launch it to near the first waypoint, run the mission, and have the final waypoint near where I am, then manually land it. I just don't trust the Spark to manually land itself. Too many variables. What do you do if child runs directly under your aircraft while it is auto-landing? I guess you could hit the sports mode switch to cancel the mission, but much easier to just land it manually. I would also like to see your mission. There is likely something in the programming you missed. It helps to have someone else double-check your programming.
 
  • Like
Reactions: Spark 317

New Threads

Members online

Forum statistics

Threads
13,104
Messages
109,121
Members
16,530
Latest member
Sean_OL