Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Constant disconnect of RC and Spark.

Sctcorolla

Member
Join
May 31, 2017
Messages
23
Age
52
It's frustrating, my RC and AC keeps getting disconnected. It gets disconnected after just a few minutes. Good thing I really haven't flown it and just been hovering testing it out outside. Cause ones it disconnects I can't control the AC. My first hover got disconnected and I had to wait for the battery to drain and it just landed itself. I've tried reconnecting by power cycling the RC and relaunching the app on my phone while the Spark hovered. Nothing works. I'm gonna contact DJI for help. Any suggestions welcome. Thanks.
 

joelb727

Member
Join
May 30, 2017
Messages
9
Age
47
Some have said to try 2.4ghz. Also looks like today's firmware update is trying to address this.
 

jimbug

Well-Known Member
Join
May 27, 2017
Messages
227
Age
68
Have you updated firmware? They released new update today and this one of the supposed fixes in it.
 
  • Like
Reactions: joelb727

joelb727

Member
Join
May 30, 2017
Messages
9
Age
47
Sctcorolla, fwiw, I was having the same issues as you. Rc disconnecting constantly and choppy flying response from rc. Yesterday, I tried everything. Recalibrated everything. 2.4ghz. Nothing was working for me. Upgraded firmware this morning and tested indoors briefly. Response is smooth today and it did not disconnect during the 5 minutes I tested. I will do further testing before risking it outside as we live on water.
 

mavicpilot

Member
Join
Jun 16, 2017
Messages
22
Age
41
Same thing folks over here. I did not try 5.8 ghz, but I found that it worked flawlessly (still limited to 2100' from home point before failing) if you get out of areas with wifi and electromagnetic interference.

My first flight was hindered to 900' over a marsh, but I guess the power lines affected the RC. The second (long) flight was on an open beach with no houses around and very few people (cell interference).
 

Sctcorolla

Member
Join
May 31, 2017
Messages
23
Age
52
Nothing is working for me, recalibration, 2.4 or 5.8ghz, firmware upgrade even did it thru DJI assistant 2. It would only stay connected for a minute then lose connection. Sometimes immediately when motors started. When connection is lost, spark would just hover and self lands after battery is drained. Luckily I've only been testing 5-10 feet hover. No luck, sadly spark is going back to DJI for a replacement. DJI tech support tried everything but problem persisted.
 

mavicpilot

Member
Join
Jun 16, 2017
Messages
22
Age
41
Nothing is working for me, recalibration, 2.4 or 5.8ghz, firmware upgrade even did it thru DJI assistant 2. It would only stay connected for a minute then lose connection. Sometimes immediately when motors started. When connection is lost, spark would just hover and self lands after battery is drained. Luckily I've only been testing 5-10 feet hover. No luck, sadly spark is going back to DJI for a replacement. DJI tech support tried everything but problem persisted.
I am curious if you are using an iOS or android device? I find that I need to force close the app and then re-launch the newest DJI Go 4 app to make things finally work. In some extreme cases I need to reboot the entire phone... I guess I am lucky that it shows disconnected, but the feed still works and the RC works.

I guess that brings up another question, are you using the RC or only the phone for the controller? After owning a parrot, I refused to even consider trying to fly a DJI with just the flat touch screen, so the RC was a must.
 

Sctcorolla

Member
Join
May 31, 2017
Messages
23
Age
52
I believe it has nothing to do with what your using if either ios or Android because the Spark disconnects with the RC. The green light on your RC turns red when it gets disconnected. Mine loses connection with or without a phone/tablet used.
 

MKF

New Member
Join
Mar 15, 2018
Messages
1
Age
31
I also faced the same problem. I cant even fly my spark. Keep disconnected lately. Hopefully dji team can assist me.on this. Thanks
 

MASERONE

Well-Known Member
Join
Nov 25, 2017
Messages
67
Age
58
hello everyone happened to me just yesterday ... radio and spark continued to disconnect each other green lece on the radio then red then green again .. just 20 meters from me ... with the cable I disconnected the phone and the cable but the problem was clear that it was between radio and spark I was very angry and I started the shipping procedure in the Netherlands with dji.poi turning on the Italian forum and asking I did the factory reset then re-installed firmware 900 and made imu calibration. tried today reached 1700 meters with cable then I decided to do rth and curiosity without cable only with wi-fi reached 700 meters !!! I would say satisfied
 

New Threads

Forum statistics

Threads
11,890
Messages
99,364
Members
15,690
Latest member
juwitacindy