Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

How to connect Tab S2 to RC with OTG

koffe

Well-Known Member
Join
Oct 14, 2017
Messages
117
Loc
Sweden
My problem was that I could not connect myTab S2 to the RC with an OTG Cable. It worked without problems with my Galaxy S5 phone, so the cable was ok. But the Tab S2 refused. After reading numerous of pages and questions with answeres both here and on other forums, I got it a little more clear. But I had to try the connections many, many times before I got it working. The following steps seem to be working for me. If I jump over a single step or mix the order, it does not work. Not here at least.


Firstly, you need to get the Developer Options menu, but this need only to be done once. If you already have it, proceed to number 1 below. Otherwise start with:
- Settings and go to About Device
- Scroll down to Build Number
- Tap it 7 times and continue
- Left panel now has the new menu Developer Options



To connect the Tab S2 to the RC follow these steps EVERY time as the Tab S2 needs to follow the whole reboot procedure to work.

1. Disable WiFi
2. Go to Settings and tap Developer Options
3. Set the On/Off toggle to On
4. Under USB-configuration choose RNDIS and go back
5. Start the RC and wait for red status
6. Connect the micro USB to the Tab S2 and then connect the OTG cable to the RC
7. Accept if a message says slowly charging
8. Reboot the Tab S2
9. Accept the GO4 app to be default
10. Then you should be connected
11. Start the Spark
12. GO FLYING

If the OTG connection come disengaged, you have to start over from 1 and run every step again.

Hope this will help somebody, as I have seen that I was not the only one with this problem.
 
  • Like
Reactions: hendywidodo

New Posts

Members online

Forum statistics

Threads
14,389
Messages
117,694
Members
17,538
Latest member
alltwensev