Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

IMU Calibration Error Code 50- WTF!!! (SOLVED)

Baqca Sanke

Well-Known Member
Join
Jul 23, 2018
Messages
48
Age
30
Hey yall,
can anyone shed some light onto my IMU problems?
I never had any IMU problem with my spark in the past. I got hit by a car and couldn't walk so i didnt fly for a while. Spark sat in the box on my shelf all nice and snug. I can finally backpack again and i can't for the life of me get this POS to calibrate the IMU. It's effectively grounded. I've tried everything. And no, it's not the "i didnt switch orientations fast enough" problem noobies get. I've had the thing a while.

It never even gets past part one of IMU calibration. It errors out Code 50 every time. Can't find anything on here about that particular problem.

I'm so pissed off because this thing aint cheap and i never once crashed it or got it wet or nothing. I even made sure to do a little maintenance charging on the lipos so they wouldn't get dead by sitting to long.

Can anyone please help me? I'm about to toss this thing in the fire pit lol

just a repeat, on the IMU calibration page, the spark icon never switches, it never gets past part one before error code 50 pops up
 
Last edited:

Spark 317

Well known member with a Spark and a Mavic Air 2.
Premium Pilot
Join
Jul 10, 2017
Messages
4,801
Loc
Indiana, USA
  • Like
Reactions: Dragonfly Joe

Baqca Sanke

Well-Known Member
Join
Jul 23, 2018
Messages
48
Age
30
Not sure what wasn’t clear, my problem is NOT the one outlined in the thread you linked. Thats the noobie prob of not switching the orientation fast enough. My spark does not even get to screen 2/6, as i mentioned. They are Not the same problem but thanks anyway.
 

Spark 317

Well known member with a Spark and a Mavic Air 2.
Premium Pilot
Join
Jul 10, 2017
Messages
4,801
Loc
Indiana, USA
Not sure what wasn’t clear, my problem is NOT the one outlined in the thread you linked. Thats the noobie prob of not switching the orientation fast enough. My spark does not even get to screen 2/6, as i mentioned. They are Not the same problem but thanks anyway.

I responded to your post in that thread with a Google link to other sites with similar problems.

Did you read it?



I understand that you are not experiencing the step / orientation process.

Here's the Google link again. :)
 

Baqca Sanke

Well-Known Member
Join
Jul 23, 2018
Messages
48
Age
30
I responded to your post in that thread with a Google link to other sites with similar problems.

Did you read it?



I understand that you are not experiencing the step / orientation process.

Here's the Google link again. :)

Yes thanks i went through that and many other imu threads. Unfortunately the concensus seems “send it to dji” or “hit it with a rubber mallet because the imu is stuck” none lf the threads seem to fix this particular imu problem.

And both of those options seems kinda dumb lol. I mean, i hit it a few times anyways.... (didnt work) but i dont like the idea of having to send a product to get repaired when theres no reason it should have stopped in the first place. And esp if i’m paying for it

I’m just disheartened because i’ve owned 2 dji drones now and i feel like i’ve spent more hours trying to get them to work than actually flying them. It’s just one problem after another 🤷‍♂️

Thanks for the help tho!
 

Tentoes

Well-Known Member
Join
Jun 5, 2019
Messages
483
Loc
Oklahoma USA
Yea. Try resetting as above. Mine had an annoying problem and all I got was "You'll have to live with it." Till it wouldn't connect so I reset it. Annoying problem went away. See if that lets you collaborate the imu.
 

Baqca Sanke

Well-Known Member
Join
Jul 23, 2018
Messages
48
Age
30
Yea. Try resetting as above. Mine had an annoying problem and all I got was "You'll have to live with it." Till it wouldn't connect so I reset it. Annoying problem went away. See if that lets you collaborate the imu.


How do i reset it? Also i downloaded this dji assistant and it doesnt recognize my spark at all
 

Baqca Sanke

Well-Known Member
Join
Jul 23, 2018
Messages
48
Age
30
So i did a reset. also tried re installing firmware. Also tried putting it in freezer to make sure it was cold....

Nothing worked
 

Tentoes

Well-Known Member
Join
Jun 5, 2019
Messages
483
Loc
Oklahoma USA
Don't think I can be much more help. I'm not exactly an expert.
 

RotorWash

Well-Known Member
Premium Pilot
Join
Jul 18, 2019
Messages
976
Age
54
Loc
P.E.I., Canada
just a repeat, on the IMU calibration page, the spark icon never switches, it never gets past part one before error code 50 pops up
Sounds like you've tried most everything. Curious though, when it's on step one have you tried changing to position two before it errors out, regardless of the picture? I ask as some say they've had success doing so even though the visual itself remained stuck on step one throughout the process. Do the status indicators ever flash green at any point during a calibration attempt?
 

Baqca Sanke

Well-Known Member
Join
Jul 23, 2018
Messages
48
Age
30
Sounds like you've tried most everything. Curious though, when it's on step one have you tried changing to position two before it errors out, regardless of the picture? I ask as some say they've had success doing so even though the visual itself remained stuck on step one throughout the process. Do the status indicators ever flash green at any point during a calibration attempt?
Last i remember the LEDs did not ever turn green. However the very last time i tried it i put the whole bird in the freezer for 20 minutes first, and it DID seem to go a little farther in the process (the status bar got further before erroring) so maybe i will try this today.. I'll do the freezer thing but also switch the orientation even if the app doesn't prompt me.

fingers crossed 🤞
The spring is coming fast and the flowers are already starting to bloom, i really WANT THIS BIRD TO BE IN THE AIR ASAP
 
  • Like
Reactions: SoccerRef12

Baqca Sanke

Well-Known Member
Join
Jul 23, 2018
Messages
48
Age
30
I GOT IT! I F*CKING GOT IT!
As of 1144 eastern time the BIRD IS FLYING 🤪😜🥳🥳👾

The LEDS did not work, nor did the app prompt screen.
I memorized the exact imu calibration orientation sequence before hand from the video in the link provided (got that sequence in my brain now lol). I started the IMU calibration after a nice chill in the a freezer. The app showed the drone in the starting position as always. The LEDs were flashing red yellow green (the same as before starting calibration). I watched the little progress bar go a little, remembering that it would only get so far before timing out.

At about that point i changed to the second orientation... the LEDs remained flashing red yellow green.
BUT i heard a little sound from the gimbal, and i attuned my self to my little Birdie. It sounded like the gimbal was trying to orient itself sideways, but then stopped and readjusted itself to be in line with the birds orientation. The progress bar went a little farther, and with intuition i changed to position 3.
The LEDS remained flashing, but i hadn't errored out yet. So i listened close, and when the gimbal made that little sound i changed to position 4.
The progress bar went a little farther, and i kept listening for that gimbal (god bless that little gimbal). LEDs kept flashing and no change in the app picture still. The gimbal sound happened again so i changed to position 5 (camera pointing up).
Here's where it got real interesting...

In position 5 the LEDs switched to yellow, and the progress bar went farther. I did not hear another gimbal sound for awhile, but because the LEDs changed to yellow i had a feeling to just wait it out. It sat there, the progress bar kept going, and going. I kept getting nervous and wanting to move it but i didn't. It felt like an eternity (was probably 3 minutes, but like a really long 3 minutes)
FINALLY the LEDs flashed to green, and the App woke it's dumb *ss up and the picture changed to show the drone on its back! For only a second then it switched to the upside down position 6. So i switched the drone, LEDs now yellow. A moment went by and the progress bar went basically to the end, the LEDs flashed to green and the app now prompted to switch to position 1.

I complied. Now it ran through the entire sequence a second time, but this time the app worked as normal, and the LEDs also worked as normal. The 2nd time took much less time and it said "Calibration successful, please restart the drone".
With trepidation i restarted the drone, and when it reconnected to the app it said ready to fly. I went outside, heart pounding, sweat dripping down my armpits. It took off without a problem. I only flew for a few moments because i have a lot of trees in my backyard.

With any luck tomorrow when i get off work i can go out into the mountains and fly!

Sorry for the long post but this was a problem seemingly without end. And this community helped me fix it without having to pay for DJI repair 👍.

Spread the word to any one else who may be having this RIDICULOUS problem.

Thank you everyone who posted to this thread
 

SoccerRef12

Well-Known Member
Join
Jul 5, 2019
Messages
524
Age
68
Wow! Truly amazing. I could feel the joy in your heart. Good for you and a big thumbs up to the entire Spark community for helping you out.
 
  • Like
Reactions: RotorWash

Scoot

New Member
Join
Jul 14, 2020
Messages
2
Age
50
Yes! This worked for me

Instead of starting out like pictures, I put the spark in an upright position, then it calibrated itself from there.

Prior it just would not go past the first position at all and kept error -50.
 

Sinclair48K

New Member
Join
Jul 26, 2017
Messages
1
Age
52
Yes! This worked for me

Instead of starting out like pictures, I put the spark in an upright position, then it calibrated itself from there.

Prior it just would not go past the first position at all and kept error -50.
YES, my error was exactly yours and doin g exactly the same fixed my issue also. I hadn't flown it for a year and just could not get past the first screen. Putting it in the upright position allowed it to complete and now its totally fine. Weird !!!!!!
 

New Threads

Forum statistics

Threads
13,379
Messages
111,300
Members
16,664
Latest member
Alex Scullion