Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

IMU Calibration Error Code 50- WTF!!! (SOLVED)

Put drone in different orientations as if you where calibrating it ,such as on it sides and while preforming imu calibration it will catch up basically it helps calibrate the app is not going to specify this only give you error code
 
I GOT IT! I F*CKING GOT IT!
As of 1144 eastern time the BIRD IS FLYING ?????

The LEDS did not work, nor did the app prompt screen.
I memorized the exact imu calibration orientation sequence before hand from the video in the link provided (got that sequence in my brain now lol). I started the IMU calibration after a nice chill in the a freezer. The app showed the drone in the starting position as always. The LEDs were flashing red yellow green (the same as before starting calibration). I watched the little progress bar go a little, remembering that it would only get so far before timing out.

At about that point i changed to the second orientation... the LEDs remained flashing red yellow green.
BUT i heard a little sound from the gimbal, and i attuned my self to my little Birdie. It sounded like the gimbal was trying to orient itself sideways, but then stopped and readjusted itself to be in line with the birds orientation. The progress bar went a little farther, and with intuition i changed to position 3.
The LEDS remained flashing, but i hadn't errored out yet. So i listened close, and when the gimbal made that little sound i changed to position 4.
The progress bar went a little farther, and i kept listening for that gimbal (god bless that little gimbal). LEDs kept flashing and no change in the app picture still. The gimbal sound happened again so i changed to position 5 (camera pointing up).
Here's where it got real interesting...

In position 5 the LEDs switched to yellow, and the progress bar went farther. I did not hear another gimbal sound for awhile, but because the LEDs changed to yellow i had a feeling to just wait it out. It sat there, the progress bar kept going, and going. I kept getting nervous and wanting to move it but i didn't. It felt like an eternity (was probably 3 minutes, but like a really long 3 minutes)
FINALLY the LEDs flashed to green, and the App woke it's dumb *ss up and the picture changed to show the drone on its back! For only a second then it switched to the upside down position 6. So i switched the drone, LEDs now yellow. A moment went by and the progress bar went basically to the end, the LEDs flashed to green and the app now prompted to switch to position 1.

I complied. Now it ran through the entire sequence a second time, but this time the app worked as normal, and the LEDs also worked as normal. The 2nd time took much less time and it said "Calibration successful, please restart the drone".
With trepidation i restarted the drone, and when it reconnected to the app it said ready to fly. I went outside, heart pounding, sweat dripping down my armpits. It took off without a problem. I only flew for a few moments because i have a lot of trees in my backyard.

With any luck tomorrow when i get off work i can go out into the mountains and fly!

Sorry for the long post but this was a problem seemingly without end. And this community helped me fix it without having to pay for DJI repair ?.

Spread the word to any one else who may be having this RIDICULOUS problem.

Thank you everyone who posted to this thread
Your thread has gave me hope, as i could not continue attempting the dumb calibration any more.... I'm going to give this a shot! Gonna put bird in the freezer, and either go through process as app isn't working correctly and re position accordingly the best I can, and or start with the drone upright and continue...right.?.haha..wish me luck!
 
I GOT IT! I F*CKING GOT IT!
As of 1144 eastern time the BIRD IS FLYING ?????

The LEDS did not work, nor did the app prompt screen.
I memorized the exact imu calibration orientation sequence before hand from the video in the link provided (got that sequence in my brain now lol). I started the IMU calibration after a nice chill in the a freezer. The app showed the drone in the starting position as always. The LEDs were flashing red yellow green (the same as before starting calibration). I watched the little progress bar go a little, remembering that it would only get so far before timing out.

At about that point i changed to the second orientation... the LEDs remained flashing red yellow green.
BUT i heard a little sound from the gimbal, and i attuned my self to my little Birdie. It sounded like the gimbal was trying to orient itself sideways, but then stopped and readjusted itself to be in line with the birds orientation. The progress bar went a little farther, and with intuition i changed to position 3.
The LEDS remained flashing, but i hadn't errored out yet. So i listened close, and when the gimbal made that little sound i changed to position 4.
The progress bar went a little farther, and i kept listening for that gimbal (god bless that little gimbal). LEDs kept flashing and no change in the app picture still. The gimbal sound happened again so i changed to position 5 (camera pointing up).
Here's where it got real interesting...

In position 5 the LEDs switched to yellow, and the progress bar went farther. I did not hear another gimbal sound for awhile, but because the LEDs changed to yellow i had a feeling to just wait it out. It sat there, the progress bar kept going, and going. I kept getting nervous and wanting to move it but i didn't. It felt like an eternity (was probably 3 minutes, but like a really long 3 minutes)
FINALLY the LEDs flashed to green, and the App woke it's dumb *ss up and the picture changed to show the drone on its back! For only a second then it switched to the upside down position 6. So i switched the drone, LEDs now yellow. A moment went by and the progress bar went basically to the end, the LEDs flashed to green and the app now prompted to switch to position 1.

I complied. Now it ran through the entire sequence a second time, but this time the app worked as normal, and the LEDs also worked as normal. The 2nd time took much less time and it said "Calibration successful, please restart the drone".
With trepidation i restarted the drone, and when it reconnected to the app it said ready to fly. I went outside, heart pounding, sweat dripping down my armpits. It took off without a problem. I only flew for a few moments because i have a lot of trees in my backyard.

With any luck tomorrow when i get off work i can go out into the mountains and fly!

Sorry for the long post but this was a problem seemingly without end. And this community helped me fix it without having to pay for DJI repair ?.

Spread the word to any one else who may be having this RIDICULOUS problem.

Thank you everyone who posted to this thread
I got it fixed as well by starting in the vertical position!!! Wohoo!!
 
  • Like
Reactions: SoccerRef12
Holly Cow!! I was also having trouble with the calibrations so instead of placing the drone in the freezer I thought I would first try the vertical suggestion and I'll be damned it worked. Thanks all for your post.
 
CONFIRMED! This works. I created this account specifically to verify to others that, as of November 2023, this still works. I'll go over some information regarding my drone's error.

I first noticed this error after having my drone in storage for 4 months while moving to a new house. When I got back to it and turned it on, it wasn't working and, as probably many of you here have experienced, it wouldn't go past the first stage of IMU Calibration, before failing to Error Code 50. I read these instructions (thanks @Baqca Sanke) and after some brief trial and error, I managed to get it to work.

Here's what I did, broken down into steps for ease of understanding.



Step 1: This one's important not to skip over, put your spark in the freezer for 15 minutes. This is how long I put it in the freezer. Why? Because the calibration bar doesn't move very far before erroring out unless the unit is cold. I wouldn't leave it for too long, as I don't know how soon the electronics would be damaged.

Step 2: Remove drone from freezer and set up your DJI app on your mobile device, start and connect to the drone, and navigate to the IMU Calibration screen.

Step 2a (optional): If you don't know the orientations that the calibration will take you through, here's DJI's official video on how to do it. I'd keep this on hand for the next steps.

Step 3: Hit Calibrate for the IMU. You should notice that when the drone is cold, the bar goes farther before erroring out. IIRC, I let the bar get to about above the middle of the first "a" in the prompt below the progress bar ("Calibrating, please wait..."), and then move it to the second position before it prompts you to. This may seem counterproductive, but doing this will start the fix.

Step 4: Once again, OP is correct. You should listen to the gimbal for a small noise (which is the gimbal trying to level itself out relative to Position 1). After the drone realizes it's not in Position 1, you will hear the noise and see the camera try to level itself relative to Position 2. As soon as the camera stops moving, move the drone to the next position. The same thing will happen each time after you're done with the previous Position. This is why Step 2a is good to do.

Step 5: Repeat Step 4 until the drone is calibrated.

Step 6: Restart the drone after calibration is complete to verify that it works. Your drone should be back to life after this!
 
CAPITO! SE*CAZZO HO CAPITO!
A partire dal 1144, ora orientale, l'UCCELLO STA VOLANDO ?????

I LED non funzionavano, né la schermata dei messaggi dell'app.
Ho memorizzato in anticipo l'esatta sequenza di orientamento della calibrazione dell'imu dal video nel collegamento fornito (ho quella sequenza nel mio cervello ora lol). Ho iniziato la calibrazione dell'IMU dopo un bel brivido nel congelatore. L'app mostrava come sempre il drone nella posizione di partenza. I LED lampeggiavano in rosso giallo verde (come prima di iniziare la calibrazione). Ho guardato la piccola barra di avanzamento spostarsi un po', ricordando che sarebbe arrivata solo fino a quel punto prima di scadere.

A quel punto sono passato al secondo orientamento... i LED continuavano a lampeggiare rosso giallo verde.
MA ho sentito un piccolo suono dal gimbal e mi sono sintonizzato con il mio piccolo Birdie. Sembrava che il gimbal stesse cercando di orientarsi lateralmente, ma poi si fermò e si riadattò per essere in linea con l'orientamento dell'uccello. La barra di avanzamento è andata un po' più in là e con l'intuito sono passato alla posizione 3.
I LED continuavano a lampeggiare, ma non avevo ancora commesso un errore. Quindi ho ascoltato attentamente e quando il gimbal ha emesso quel piccolo suono sono passato alla posizione 4.
La barra di avanzamento è andata un po' più avanti e ho continuato ad ascoltare quel gimbal (dio benedica quel piccolo gimbal). I LED continuavano a lampeggiare e non c'era ancora alcun cambiamento nell'immagine dell'app. Il suono del gimbal si è ripetuto, quindi sono passato alla posizione 5 (fotocamera rivolta verso l'alto).
Ecco dove la cosa è diventata davvero interessante...

Nella posizione 5 i LED sono diventati gialli e la barra di avanzamento è andata avanti. Non ho sentito un altro suono del gimbal per un po', ma poiché i LED sono diventati gialli ho avuto la sensazione di aspettare che finisse. Rimase lì, la barra di avanzamento continuava ad andare avanti. Continuavo a innervosirmi e volevo spostarlo, ma non l'ho fatto. Sembrava un'eternità (probabilmente erano 3 minuti, ma 3 minuti davvero lunghi)
FINALMENTE i LED sono diventati verdi e l'app si è svegliata completamente stupida e l'immagine è cambiata per mostrare il drone sulla schiena! Per solo un secondo è passato alla posizione capovolta 6. Quindi ho acceso il drone, i LED ora sono gialli. Passò un momento e la barra di avanzamento arrivò praticamente alla fine, i LED diventarono verdi e l'app ora chiese di passare alla posizione 1.

Ho obbedito. Ora è stata eseguita l'intera sequenza una seconda volta, ma questa volta l'app ha funzionato normalmente e anche i LED hanno funzionato normalmente. La seconda volta ha richiesto molto meno tempo e diceva "Calibrazione riuscita, riavviare il drone".
Con trepidazione ho riavviato il drone e quando si è ricollegato all'app ha detto pronto a volare. Sono uscito con il cuore che batteva forte e il sudore che mi colava lungo le ascelle. È decollato senza problemi. Ho volato solo per pochi istanti perché ho molti alberi nel mio giardino.

Con un po' di fortuna domani, quando esco dal lavoro, posso andare in montagna e volare!

Scusate il post lungo ma questo era un problema apparentemente senza fine. E questa community mi ha aiutato a risolverlo senza dover pagare per la riparazione DJI?.

Spargi la voce a chiunque altro possa avere questo problema RIDICOLO.

Grazie a tutti coloro che hanno postato in questo thread
Ciao, ho il tuo stesso problema, ma non ho provato ancora a metterlo nel congelatore.. Oggi provo così, (nel congelatore va inserito con tutta la batteria?) poi non ho capito bene una cosa, tu la prima fase/posizione come l hai messo? Quello di partenza standard?? Sono letteralmente disperato
 
I GOT IT! I F*CKING GOT IT!
As of 1144 eastern time the BIRD IS FLYING ?????

The LEDS did not work, nor did the app prompt screen.
I memorized the exact imu calibration orientation sequence before hand from the video in the link provided (got that sequence in my brain now lol). I started the IMU calibration after a nice chill in the a freezer. The app showed the drone in the starting position as always. The LEDs were flashing red yellow green (the same as before starting calibration). I watched the little progress bar go a little, remembering that it would only get so far before timing out.

At about that point i changed to the second orientation... the LEDs remained flashing red yellow green.
BUT i heard a little sound from the gimbal, and i attuned my self to my little Birdie. It sounded like the gimbal was trying to orient itself sideways, but then stopped and readjusted itself to be in line with the birds orientation. The progress bar went a little farther, and with intuition i changed to position 3.
The LEDS remained flashing, but i hadn't errored out yet. So i listened close, and when the gimbal made that little sound i changed to position 4.
The progress bar went a little farther, and i kept listening for that gimbal (god bless that little gimbal). LEDs kept flashing and no change in the app picture still. The gimbal sound happened again so i changed to position 5 (camera pointing up).
Here's where it got real interesting...

In position 5 the LEDs switched to yellow, and the progress bar went farther. I did not hear another gimbal sound for awhile, but because the LEDs changed to yellow i had a feeling to just wait it out. It sat there, the progress bar kept going, and going. I kept getting nervous and wanting to move it but i didn't. It felt like an eternity (was probably 3 minutes, but like a really long 3 minutes)
FINALLY the LEDs flashed to green, and the App woke it's dumb *ss up and the picture changed to show the drone on its back! For only a second then it switched to the upside down position 6. So i switched the drone, LEDs now yellow. A moment went by and the progress bar went basically to the end, the LEDs flashed to green and the app now prompted to switch to position 1.

I complied. Now it ran through the entire sequence a second time, but this time the app worked as normal, and the LEDs also worked as normal. The 2nd time took much less time and it said "Calibration successful, please restart the drone".
With trepidation i restarted the drone, and when it reconnected to the app it said ready to fly. I went outside, heart pounding, sweat dripping down my armpits. It took off without a problem. I only flew for a few moments because i have a lot of trees in my backyard.

With any luck tomorrow when i get off work i can go out into the mountains and fly!

Sorry for the long post but this was a problem seemingly without end. And this community helped me fix it without having to pay for DJI repair ?.

Spread the word to any one else who may be having this RIDICULOUS problem.

Thank you everyone who posted to this thread
Thanks for posting this “long post”. It was worth every word. It worked for me too. Thanks again!
 

Members online

No members online now.

Forum statistics

Threads
14,610
Messages
118,841
Members
18,038
Latest member
tomi503