Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Rear LEDs flashing Green, Yellow, Red

tmarsh0494

New Member
Join
Dec 4, 2018
Messages
3
Age
26
Last week I took off and flew over a metal roof 5 seconds into flight, and got a compass error and weak GPS. My spark flew away with no GPS signal, and after searching for 4 hours I found it. Thankfully. I thought for sure it was a lost cause.
When I try to power it up, it does the startup chime, front LEDs go red like normal, back flash green yellow red. Then a pause, and the back continue to flash green yellow red indefinitely. Can’t find anything in a quick search that explains the back LEDs flashing green yellow red.
 

Spark 317

Well known member with a Spark.
Premium Pilot
Join
Jul 10, 2017
Messages
4,676
Loc
Indiana, USA
Last week I took off and flew over a metal roof 5 seconds into flight, and got a compass error and weak GPS. My spark flew away with no GPS signal, and after searching for 4 hours I found it. Thankfully. I thought for sure it was a lost cause.
When I try to power it up, it does the startup chime, front LEDs go red like normal, back flash green yellow red. Then a pause, and the back continue to flash green yellow red indefinitely. Can’t find anything in a quick search that explains the back LEDs flashing green yellow red.

Hello from the Hoosier Heartland tmarsh0494.

It looks like it may be stuck in the start up / systems check?

You may have to recalibrate the compass.

According to the DJI manual and the status lights.

Screenshot_20190208-064409~2.png

Good luck and welcome to the Forum. :)
 

Roy Talangbayan

Well-Known Member
Join
Aug 30, 2017
Messages
46
Last week I took off and flew over a metal roof 5 seconds into flight, and got a compass error and weak GPS. My spark flew away with no GPS signal, and after searching for 4 hours I found it. Thankfully. I thought for sure it was a lost cause.
When I try to power it up, it does the startup chime, front LEDs go red like normal, back flash green yellow red. Then a pause, and the back continue to flash green yellow red indefinitely. Can’t find anything in a quick search that explains the back LEDs flashing green yellow red.
Try doing an IMU calibration
 

New Threads

Members online

Forum statistics

Threads
13,187
Messages
109,809
Members
16,575
Latest member
Honza