Welcome DJI Spark Pilot!
Jump in and join our free Spark community today!
Sign up

Advice on OTG

Antiboost

Member
Join
Jul 29, 2021
Messages
14
Age
52
I have a new OTG cable. It was sold as specific for DJI drone OTG I'm running stock latest firmware. It's micro usb to usb c on phone.
However I'm still having to connect the Spark via WiFi.
I saw a post saying enable usb debugging, but my phone's new on Android 11 and the extra setting didn't match the post.
 

nilanjan118

Well-Known Member
Join
Oct 31, 2018
Messages
1,022
You need to enable "Developer options" menu first.
Go to settings, tap on "About phone/device".
Then tap on "Build number" multiple times (7~10 times) till a prompt shows up.
 
  • Like
Reactions: Spark 317

Roland

Well-Known Member
Join
Jul 30, 2019
Messages
166
Age
63
I thought it was disable USB bugging . WIFI on phone off and be sure the RC is charging your phone and not vice versa
 

Spark 317

Well known member with a Spark and a Mavic Air 2.
Premium Pilot
Join
Jul 10, 2017
Messages
5,020
Loc
Indiana, USA
I have a new OTG cable. It was sold as specific for DJI drone OTG I'm running stock latest firmware. It's micro usb to usb c on phone.
However I'm still having to connect the Spark via WiFi.
I saw a post saying enable usb debugging, but my phone's new on Android 11 and the extra setting didn't match the post.


Another bit of information` when using the OTG cable, be sure to disable the Wi-Fi on the device.

Airplane mode may not be enough as some airliners provide a Wi-Fi service during the flight. Airplane mode disables the cellular data stream. Check your device settings to be sure the Wi-Fi is OFF.

The Spark has a sneaky way of connecting to the Wi-Fi even when the cable is connected. At least that has been my experience in the past.

Good luck. :)


.
 
  • Like
Reactions: Engie

RPL

Well-Known Member
Join
Jul 17, 2018
Messages
272
Agree with the above post. Often times, airplane mode doesn’t disable WiFi connectivity. Be sure to make sure that your WiFi is disabled before trying to use the OTG cable. I fly mine with the iPhone 12 Pro Max and have zero issues.
 

Engie

Well-Known Member
Join
Jul 1, 2020
Messages
57
Age
86
Another bit of information` when using the OTG cable, be sure to disable the Wi-Fi on the device.

Airplane mode may not be enough as some airliners provide a Wi-Fi service during the flight. Airplane mode disables the cellular data stream. Check your device settings to be sure the Wi-Fi is OFF.

The Spark has a sneaky way of connecting to the Wi-Fi even when the cable is connected. At least that has been my experience in the past.

Good luck. :)


.
Hi thanks for that advice that answers my questions on my previous reply.Engie.
 

Jcpereir

New Member
Join
Dec 14, 2018
Messages
2
Age
56
Agree with the above post. Often times, airplane mode doesn’t disable WiFi connectivity. Be sure to make sure that your WiFi is disabled before trying to use the OTG cable. I fly mine with the iPhone 12 Pro Max and have zero issues.
Witch cable are you using?
 

New Posts

Members online

Forum statistics

Threads
14,475
Messages
118,157
Members
17,715
Latest member
rsugdenmd